Bug 208512 - Qt application uic not called during build
Qt application uic not called during build
Status: RESOLVED DUPLICATE of bug 207131
Product: cnd
Classification: Unclassified
Component: Project
7.1
PC Windows 7
: P1 (vote)
: TBD
Assigned To: igor_nikiforov
issues@cnd
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-16 14:07 UTC by johngull
Modified: 2012-02-17 08:20 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description johngull 2012-02-16 14:07:42 UTC
Hello,

 Netbeans 7.1 have very bad bug now for Qt applications.

repeat this steps:
  - create "qt Application" project
  - add new "qt form"
  - click "build"

oops, there is no "ui_...h" - it was not generated.

And it happens always now. The only what helps - restart of netbeans. But if you change ui file, you need to restart netbeans - not very comfort.

Please try to make fast fix.
Comment 1 igor_nikiforov 2012-02-16 14:17:54 UTC

*** This bug has been marked as a duplicate of bug 207131 ***
Comment 2 johngull 2012-02-16 15:08:26 UTC
The "bug 207131" is about qrc files management. i had reported about ui files.
Is it solved with same fix?

And if it is fixed, when we can hope to see it in update of cnd plugins?

Thanks.
Comment 3 Vladimir Voskresensky 2012-02-16 15:37:56 UTC
It would be great if you can try dev build (please, backup your project) and verify it is really fixed => it proves, that it is fixed or not fixed in upcoming 7.1.1 update
Comment 4 Vladimir Voskresensky 2012-02-16 15:41:19 UTC
http://bits.netbeans.org/download/trunk/nightly/latest/
Comment 5 johngull 2012-02-17 07:38:43 UTC
Yes, in nightly build all works fine with *.ui files.

Is it possible to update cnd through update service before 7.1.1 release?
Comment 6 soldatov 2012-02-17 07:51:28 UTC
(In reply to comment #5)
> Yes, in nightly build all works fine with *.ui files.
> 
> Is it possible to update cnd through update service before 7.1.1 release?
NetCat users (http://wiki.netbeans.org/NetCAT) can update NetBeans before release
Comment 7 igor_nikiforov 2012-02-17 08:18:36 UTC
As you have verified this, I'm closing the Bug now.
If you will find some issues with the fix feel free to reopen it.

BTW, the simple workaround is to close Qt project and open it again.

*** This bug has been marked as a duplicate of bug 207131 ***
Comment 8 johngull 2012-02-17 08:20:40 UTC
> As you have verified this, I'm closing the Bug now.
> If you will find some issues with the fix feel free to reopen it.

  Yes, bug can be marked as solved.
 
> BTW, the simple workaround is to close Qt project and open it again.
 Sorry, but this is not acceptable workaround. Especcialy when you have project with 25 dependencies.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo