Bug 207131 - *.qrc files are ignored when adding to the project
*.qrc files are ignored when adding to the project
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Project
7.1
PC Windows XP
: P2 (vote)
: 7.1.1
Assigned To: igor_nikiforov
issues@cnd
71patch1-verified
:
: 208512 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-10 15:56 UTC by daorus
Modified: 2012-02-17 09:48 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description daorus 2012-01-10 15:56:58 UTC
When we add files to QT с++ project all *.qrc files are not added to the netbeans/Release.pro and therefore are not compiling.

1. they are shown in the project tree, but not added to *.pro
2. all the projects where files where added in 7.0.1 are complied ok in 7.1.0

The defect in process of addition of *.qrc files only.
Comment 1 igor_nikiforov 2012-01-12 11:53:46 UTC
I can reproduce this issue in NetBeans 7.1. *.qrc files are ignored in both cases: if existing file is added or new one is created.

It's quite a serious regression, but still this is not a P1 issue.
Downgrading to P2.
Comment 2 daorus 2012-01-12 12:53:14 UTC
> still this is not a P1 issue

What's the matter with you? This issue makes Netbeans 7.1 impossible to make QT projectes at all! This issue is about complete feature loss: netbeans 7.1 can not make QT projects anymore.

Such simple tasks like set an application icon are now just impossible for nb 7.1.
Comment 3 soldatov 2012-01-12 18:54:41 UTC
(In reply to comment #2)
> > still this is not a P1 issue
> 
> What's the matter with you? This issue makes Netbeans 7.1 impossible to make QT
> projectes at all! This issue is about complete feature loss: netbeans 7.1 can
> not make QT projects anymore.
> 
> Such simple tasks like set an application icon are now just impossible for nb
> 7.1.
1) I think you speaks about '71patch-candidate' special keyword
2) Why you can't restart NetBeans in order to fix build?
Comment 4 daorus 2012-01-12 19:10:32 UTC
> I think you speaks about '71patch-candidate' special keyword

I do not know what "patch candidate" means, but if anybody downloads the current stable version of c++ netbeans (which is 7.1) he won't be able to make qt applications with resources at all. For our qt projects nb 7.1 is completly useless. It's not about comfort, it's about complete unablity to develop qt applications.

> Why you can't restart NetBeans in order to fix build?

What d'you mean by "restart" and what is "fix build"? I do not understand you.
For now we rolled back all our nb back to 7.0.1. and go on delepment as usual.

-----------

In our qt projects the file structure of the project has the meaning and therefore we add everything through file tree first and then everytime before each build we remove everything from the project and use "Add existing items ...". That's why it is impossible for us to use 7.1 - it will not add resoures to our projects.

For qt projects it is impossible to add new items in project tree, cause in this case every item is save in the project root that that is not acceptable for us. We have strict rules for file structure of our qt projects.
Comment 5 soldatov 2012-01-12 20:04:34 UTC
(In reply to comment #4)
> What d'you mean by "restart" and what is "fix build"? I do not understand you.
> For now we rolled back all our nb back to 7.0.1. and go on delepment as usual.
- Create new Qt project
- Create new Qt Form and Qt Resource files
- Update source code
- Clean and Build project
==> Build fails. *.pro file contains:
FORMS +=
RESOURCES +=
- Push File|Exit menu item
- Launch Netbeans again (/usr/local/netbeans-7.1/bin/netbeans command)
- Clean and Build project
- Check *.pro file
==> *.pro file contains:
FORMS += newForm.ui
RESOURCES += newresource.qrc
Comment 6 daorus 2012-01-13 10:34:56 UTC
> Clean and Build project

No, thank you. We'd better stick to 7.0.1. and wait while the defect will be fixed.
Comment 7 Leonid Lenyashin 2012-01-13 10:48:42 UTC
We have priority definitions and this is a P2 (a high priority issue). I do not know how priority matter for you. I think what matters is the fix. There is an engineer assigned and looking into the issue. It is also already nominated for the next patch. So playing with priority may help to reflect your level of disappointment, but will not affect the fix delivery timeframe. 
Your problem is important for us and I can ensure you that we are doing our best to make sure it is fixed.
Thank you for using the product, providing feedback, as well as for your understanding and patience.
Leonid.
Comment 8 daorus 2012-01-13 11:34:15 UTC
> 2 Leonid

I got no claim to nb dev team, cause nb is free and it would be at least not polite to claim anything. The core idea I transfer and protect is a whole feature loss in 7.1. It can be P1, P2, P3 or anything else, but from production point of view it IS a feature loss.

Soldatov's option is not acceptable, cause some of our projects take 12-15 minutes to clean & build and that would be a hige stress for developers to fulfill all these "tambourine dances" each time they edit file structure.
Comment 9 igor_nikiforov 2012-01-13 19:10:20 UTC
I've found simple workaround for this issue: you just need to close the project with broken *.qrc and open it again.

This issue was introduced while Bug #200743 "meta files for Hotspot are regenerated during clean&build all the time" fixing. So I'll re-assign this one to Alexander for further investigation.
Comment 10 daorus 2012-01-13 19:25:08 UTC
> simple workaround for this issue: 
> you just need to close the project
> with broken *.qrc and open it again.

That's much improved solution comparing to Soldatov's one, but still comfort of doing things in 7.0.1 is much natural and productive. Thank you.
Comment 11 igor_nikiforov 2012-01-19 07:33:08 UTC
The issue is resolved:
  http://hg.netbeans.org/cnd-main/rev/ba6daebd786d
Comment 12 soldatov 2012-01-23 10:26:08 UTC
verified in NetBeans IDE Dev (Build 201201220600)
Comment 13 soldatov 2012-01-30 12:59:26 UTC
QA thinks fix can be integrated into NB 7.1.1
Comment 14 Alexander Simon 2012-02-01 13:47:24 UTC
The fix is safe and resolves issue.
Comment 15 igor_nikiforov 2012-02-01 15:41:09 UTC
The fix is transplanted to release71_fixes branch:
  http://hg.netbeans.org/releases/rev/165adc8efccc
Comment 16 igor_nikiforov 2012-02-16 14:17:54 UTC
*** Bug 208512 has been marked as a duplicate of this bug. ***
Comment 17 soldatov 2012-02-17 07:47:07 UTC
verified in NetBeans IDE 7.1 (Build 201112071828)
Comment 18 igor_nikiforov 2012-02-17 08:18:36 UTC
*** Bug 208512 has been marked as a duplicate of this bug. ***
Comment 19 soldatov 2012-02-17 09:48:17 UTC
Verified in NetBeans 7.1 with updates from 201202141941


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo