Bug 208462 - Archetype for empty JAR project
Archetype for empty JAR project
Status: RESOLVED FIXED
Product: projects
Classification: Unclassified
Component: Maven
7.1
All All
: P2 (vote)
: 8.0
Assigned To: Milos Kleint
issues@projects
: USABILITY
: 228920 (view as bug list)
Depends on:
Blocks: 230984
  Show dependency treegraph
 
Reported: 2012-02-15 15:17 UTC by Jesse Glick
Modified: 2013-11-11 13:54 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2012-02-15 15:17:00 UTC
The use of the quickstart archetype for jar-packaging projects is not ideal:

- main class created even when none is often required, and we have a separate file template for that
- do-nothing test class created even when no tests are needed (forcing user to delete JUnit dep and src/test/); again we have a separate file template for adding tests (which also adds the right source root and dep)
- sources formatted using Maven conventions rather than IDE-default Sun standard (e.g. open brace on separate line)
- meaningless <url> in POM

It would be better to have the SE archetype create a minimal project with a near-empty POM (and 4-space indents), an empty src/main/java/, and nothing else. Not sure whether this should be a new archetype in mojo-archetypes, or created directly by the IDE wizard.
Comment 1 jplatts 2012-05-27 19:50:13 UTC
In Eclipse, empty Maven projects can be created using the m2eclipse plugin without using an archetype, but the m2eclipse plugin also supports creating projects through Maven archetypes. I really would like to have similar functionality added to NetBeans.
Comment 2 athompson 2013-05-15 09:56:36 UTC
*** Bug 228920 has been marked as a duplicate of this bug. ***
Comment 3 Quality Engineering 2013-11-08 03:53:02 UTC
Integrated into 'main-silver', will be available in build *201311080001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/ae57eede91ed
User: Milos Kleint <mkleint@netbeans.org>
Log: #208462 first attempt at non-archetype based wizards
Comment 4 Milos Kleint 2013-11-11 13:54:50 UTC
http://hg.netbeans.org/core-main/rev/0d89ab87dd4b
http://hg.netbeans.org/core-main/rev/02392eb8e8b3
http://hg.netbeans.org/core-main/rev/1015cbad9511

are the final batch of changesets to create infrastructure for creating maven projects without an archetype.

so as of now, the "no archetype" solution is used for simple jar, pom and nbm projects.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo