Bug 207812 - classview.ProjectsKeyArray.getProjects [LowPerformance took 4037 ms.]
classview.ProjectsKeyArray.getProjects [LowPerformance took 4037 ms.]
Status: RESOLVED FIXED
Product: cnd
Classification: Unclassified
Component: Navigation
7.2
All All
: P3 (vote)
: 7.2
Assigned To: Alexander Simon
issues@cnd
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
: 207527 211289 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-27 08:58 UTC by Petr Cyhelsky
Modified: 2013-05-17 14:00 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (79.88 KB, application/nps)
2012-01-27 08:58 UTC, Petr Cyhelsky
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Cyhelsky 2012-01-27 08:58:10 UTC
Build: NetBeans IDE Dev (Build 20120125-2ee091eab541)
VM: OpenJDK 64-Bit Server VM, 20.0-b11, OpenJDK Runtime Environment, 1.6.0_22-b22
OS: Linux

User Comments:
jocke: started netbeans

GUEST: open netbeans

jocke: started



Maximum slowness yet reported was 6445 ms, average is 4849
Comment 1 Petr Cyhelsky 2012-01-27 08:58:25 UTC
Created attachment 115296 [details]
nps snapshot
Comment 2 Vladimir Voskresensky 2012-03-30 10:33:52 UTC
Sasha, please, have a look. There is a query from ClassView to get libraries.
Comment 3 Alexander Simon 2012-04-06 16:37:08 UTC
fixed, change set:
http://hg.netbeans.org/cnd-main/rev/9abab6175470
Comment 4 Quality Engineering 2012-04-07 10:10:43 UTC
Integrated into 'main-golden', will be available in build *201204070400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/9abab6175470
User: Alexander Simon <alexvsimon@netbeans.org>
Log: fixed Bug #207812 LowPerformance took 4037 ms.
Comment 5 Alexander Simon 2012-04-16 17:41:19 UTC
*** Bug 207527 has been marked as a duplicate of this bug. ***
Comment 6 Vladimir Voskresensky 2012-04-16 21:04:41 UTC
*** Bug 211289 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo