Bug 206611 - LowPerformance took 3371 ms: Files are read in EDT to determine MIME type
LowPerformance took 3371 ms: Files are read in EDT to determine MIME type
Status: RESOLVED DUPLICATE of bug 233429
Product: platform
Classification: Unclassified
Component: Data Systems
7.0
All All
: P3 (vote)
: TBD
Assigned To: Jaroslav Havlin
issues@platform
EXCEPTIONS_REPORT perf-profileme cndreq
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-21 09:18 UTC by Exceptions Reporter
Modified: 2013-12-18 08:04 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (11.15 KB, application/nps)
2011-12-21 09:18 UTC, Exceptions Reporter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2011-12-21 09:18:41 UTC
Build: NetBeans IDE 7.0.1 (Build 201107282000)
VM: Java HotSpot(TM) 64-Bit Server VM, 20.1-b02, Java(TM) SE Runtime Environment, 1.6.0_26-b03
OS: Linux
Maximum slowness yet reported was 43339 ms, average is 23513
Comment 1 Exceptions Reporter 2011-12-21 09:18:44 UTC
Created attachment 114386 [details]
nps snapshot
Comment 2 Jaroslav Tulach 2012-01-10 11:04:38 UTC
The snapshot seems to be invalid as it covers only 430ms and not 43s.
Comment 3 Vladimir Kvashin 2013-08-22 09:49:22 UTC
Here is a valid snapshot
http://statistics.netbeans.org/analytics/exception.do?id=687608
Comment 4 Jaroslav Tulach 2013-12-17 13:56:00 UTC
This is a duplicate of a bug Jarda already has somewhere. I would suggest to keep lastModified status of the file and don't query its mime type when its type remains the same.
Comment 5 Jaroslav Havlin 2013-12-18 08:04:12 UTC

*** This bug has been marked as a duplicate of bug 233429 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo