Bug 233429 - org.openide.nodes.CookieSetLkp.beforeLookupImpl: LowPerformance took 94370 ms.
org.openide.nodes.CookieSetLkp.beforeLookupImpl: LowPerformance took 94370 ms.
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Data Systems
7.4
All All
: P3 (vote)
: 8.0
Assigned To: Jaroslav Havlin
issues@platform
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
: 206611 239297 243250 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-25 13:37 UTC by Exceptions Reporter
Modified: 2014-03-28 16:24 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (213.47 KB, application/nps)
2013-07-25 13:37 UTC, Exceptions Reporter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2013-07-25 13:37:03 UTC
Build: NetBeans IDE Dev (Build nbms-and-javadoc-10777-on-20130422)
VM: Java HotSpot(TM) Client VM, 22.0-b10, Java(TM) SE Runtime Environment, 1.7.0_02-b13
OS: Windows XP

User Comments:
GUEST: Just opening a folder. If anyone reads these requests go with Eclipse. This tool is horrible....

GUEST: This tool is unusable. All I did was open or attempt to open a folder with three small files in it. How does NetBeans stay in business????



Maximum slowness yet reported was 94370 ms, average is 88215
Comment 1 Exceptions Reporter 2013-07-25 13:37:06 UTC
Created attachment 137799 [details]
nps snapshot
Comment 2 Jan Peska 2013-12-17 08:11:22 UTC
*** Bug 239297 has been marked as a duplicate of this bug. ***
Comment 3 Jan Peska 2013-12-17 08:15:32 UTC
org.openide.loaders.DefaultDataObject.fixCookieSet() is called several times for the same file even though it should be known if the file if binary or not after the first check -> reassigning to Data Systems
Comment 4 Jaroslav Havlin 2013-12-18 08:04:12 UTC
*** Bug 206611 has been marked as a duplicate of this bug. ***
Comment 5 Jaroslav Havlin 2013-12-19 14:36:28 UTC
If the file is binary, fixCookieSet is called several times.

http://hg.netbeans.org/core-main/rev/3cb25b68863f
Fixed.

Thank you for reporting.
Comment 6 Martin Entlicher 2014-03-28 16:24:23 UTC
*** Bug 243250 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo