Bug 206369 - UI lock when creating Anagram Game project
UI lock when creating Anagram Game project
Status: RESOLVED FIXED
Product: projects
Classification: Unclassified
Component: Generic Infrastructure
7.1
PC Linux
: P3 (vote)
: 7.2
Assigned To: Jesse Glick
issues@projects
: THREAD
Depends on:
Blocks: 191951
  Show dependency treegraph
 
Reported: 2011-12-14 12:40 UTC by Jiri Kovalsky
Modified: 2011-12-17 16:47 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Full thread dump when IDE froze upon selection Anagram Game project type. (17.16 KB, application/octet-stream)
2011-12-14 12:40 UTC, Jiri Kovalsky
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Kovalsky 2011-12-14 12:40:35 UTC
Created attachment 114155 [details]
Full thread dump when IDE froze upon selection Anagram Game project type.

Product Version: NetBeans IDE 7.1 (Build 201112071828)
Java: 1.6.0_30; Java HotSpot(TM) Client VM 20.5-b03
System: Linux Mint 10 version 2.6.35-22-generic running on i386; UTF-8; cs_CZ (nb)
User directory: /home/cesilko/.netbeans/7.1
Cache directory: /home/cesilko/.netbeans/7.1/var/cache

Description:
============
I experienced a UI lock when I wanted to create a new Anagram Game project. The "Next >" button was pressed but nothing happened. The only way to close the wizard was to press "x" window button. I generated full thread dump, application snapshot and heap dump.

What I did:
===========
1. Started IDE (userdir was already created and used before).
2. Clicked "New Project..." button in the main toolbar.
3. Selected "Samples > Java" category.
4. Selected "Anagram Game" project and clicked "Next >" button.
5. "New Project" wizard locked.
Comment 1 Jesse Glick 2011-12-14 22:51:08 UTC
Unable to reproduce with 6u30 on Ubuntu, and I cannot see from the thread dump why it is hanging. Dialog.setVisible is being called from off EQ, which might be contributing to the problem.
Comment 2 Jesse Glick 2011-12-14 23:02:58 UTC
Possibly related to fix of bug #191951.
Comment 3 Jesse Glick 2011-12-14 23:13:18 UTC
core-main #a5e8727274ae
Comment 4 Quality Engineering 2011-12-17 16:47:53 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/a5e8727274ae
User: Jesse Glick <jglick@netbeans.org>
Log: #206369: UI lock when creating Anagram Game project
Unreproducible, but using notify rather than manually creating a Dialog should be safer.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo