Bug 205917 - Bad text rendering on Mac OSX: white one-pixel horizontal lines
Bad text rendering on Mac OSX: white one-pixel horizontal lines
Status: VERIFIED FIXED
Product: editor
Classification: Unclassified
Component: Painting & Printing
7.1
PC Mac OS X
: P1 (vote)
: 7.1
Assigned To: Miloslav Metelka
issues@editor
: 71_HR_FIX, REGRESSION
: 205945 205946 206222 206500 206788 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-05 09:31 UTC by Miloslav Metelka
Modified: 2012-01-02 10:47 UTC (History)
7 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Screenshot with missing one-pixel lines in font rendering (234.03 KB, image/png)
2011-12-05 09:34 UTC, Miloslav Metelka
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Miloslav Metelka 2011-12-05 09:31:03 UTC

    
Comment 1 Miloslav Metelka 2011-12-05 09:32:13 UTC
It can be demonstrated by slowly dragging a vertical scrollbar.
Comment 2 Miloslav Metelka 2011-12-05 09:34:11 UTC
Created attachment 113812 [details]
Screenshot with missing one-pixel lines in font rendering
Comment 3 Miloslav Metelka 2011-12-05 09:43:25 UTC
This is regression due to issue 203118.
On Mac OSX using java.awt.geom.Area objects generates this problem so I've disabled that optimization (aggregation of multiple text fragments with the same foreground color into an Area object for a single TextLayout.draw() invocation). 
Still rest of the original patch should improve performance of the long lines well so the issue 203118 should remain is fixed state (QE is testing that right now).

http://hg.netbeans.org/jet-main/rev/e474a50e2dda
Comment 4 Miloslav Metelka 2011-12-05 09:54:35 UTC
Confirmed by QE that the long lines are still ok after this patch.

Integrated into release71:
e474a50e2dda transplanted to 08ce3b6cad96
Comment 5 Quality Engineering 2011-12-05 20:32:04 UTC
Integrated into 'releases'
Changeset: http://hg.netbeans.org/releases/rev/08ce3b6cad96
User: Miloslav Metelka <mmetelka@netbeans.org>
Log: #205917 - Bad text rendering on Mac OSX: white one-pixel horizontal lines.
(transplanted from e474a50e2dda0183c865bd257e11b2b5fe776af2)
Comment 6 Miloslav Metelka 2011-12-06 10:21:59 UTC
*** Bug 205946 has been marked as a duplicate of this bug. ***
Comment 7 Quality Engineering 2011-12-06 12:13:09 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/e474a50e2dda
User: Miloslav Metelka <mmetelka@netbeans.org>
Log: #205917 - Bad text rendering on Mac OSX: white one-pixel horizontal lines.
Comment 8 Marian Mirilovic 2011-12-06 20:46:29 UTC
*** Bug 205945 has been marked as a duplicate of this bug. ***
Comment 9 Tomas Danek 2011-12-09 12:21:45 UTC
v. 

Product Version: NetBeans IDE 7.1 (Build 201112071828)
Java: 1.6.0_29; Java HotSpot(TM) 64-Bit Server VM 20.4-b02-402
System: Mac OS X version 10.7.2 running on x86_64; MacRoman; en_US (nb)
User directory: /Users/tomas/.netbeans/7.1
Cache directory: /Users/tomas/.netbeans/7.1/var/cache
Comment 10 Miloslav Metelka 2011-12-18 22:10:02 UTC
*** Bug 206222 has been marked as a duplicate of this bug. ***
Comment 11 Marian Mirilovic 2011-12-29 10:39:42 UTC
*** Bug 206500 has been marked as a duplicate of this bug. ***
Comment 12 Jiri Prox 2012-01-02 10:47:26 UTC
*** Bug 206788 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo