Bug 205249 - jfxsa-run does not exist in the project when opening project from previous version
jfxsa-run does not exist in the project when opening project from previous ve...
Status: CLOSED WONTFIX
Product: javafx
Classification: Unclassified
Component: Project
7.1
PC Windows 7
: P2 (vote)
: 7.1
Assigned To: Petr Somol
issues@javafx
: RELNOTE
: 206842 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-17 17:44 UTC by esmithbss
Modified: 2012-01-04 09:19 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description esmithbss 2011-11-17 17:44:11 UTC
I have a JavaFX project that was created in Version 7.1-Beta.  When attempting to run it in 201111160600, I am provided with the message:

'Target "jfxsa-run" does not exist in the project "<project name>".'

There does not appear to be any way to add the missing tasks to the existing project or replace the jfx-impl*.xml(inc) files within the nbproject folder.

The only way to correct this error at this time appears to be to re-create the project as a new project and rebuild the project (move source code, apply settings, etc...)
Comment 1 David Strupl 2011-11-18 08:40:38 UTC
Hello, 

I don't think we need to support upgrading from Beta to Final. It was Beta - not previous version. Mariane, any input from QA about this?

Petre, how hard is to fix this or at least provide more sane error message?

Thanks,

David
Comment 2 Marian Mirilovic 2011-11-18 08:55:23 UTC
(In reply to comment #1)
> I don't think we need to support upgrading from Beta to Final. It was Beta -
> not previous version. Mariane, any input from QA about this?

Hmm, we haven't faced such problem yet. We do not support upgrade of IDE from Devs to Stable - but using projects generated by Beta in FCS should work - otherwise we need to explicitly inform users of Devs/Betas that projects generated by these bits might not work in FCS.
Comment 3 Petr Somol 2011-11-18 13:51:15 UTC
the problem follows from changes in FX project files that have been made after 7.1beta became public. The changes involved bug fixes, finalization of functionality but also changes following from important changes inside JavaFX between JavaFX 2.0 and 2.0.2 (so that NB 7.1 supports not only JavaFX 2.0 but also what is new in 2.0.2). See
http://javafx-jira.kenai.com/browse/RT-17553
http://javafx-jira.kenai.com/browse/RT-16975
http://javafx-jira.kenai.com/browse/RT-16976
http://javafx-jira.kenai.com/browse/RT-17796

NB FX project files have thus changed substantially after 7.1 and any fix that would directly make 7.1beta projects runnable in 7.1 would leave lots of functionality buggy or disabled. Important fixes that would remain dysfunctional
because they are realized partly through build script changes include:
http://netbeans.org/bugzilla/show_bug.cgi?id=203201
http://netbeans.org/bugzilla/show_bug.cgi?id=202990
http://netbeans.org/bugzilla/show_bug.cgi?id=202455
http://netbeans.org/bugzilla/show_bug.cgi?id=202821
http://netbeans.org/bugzilla/show_bug.cgi?id=203224
http://netbeans.org/bugzilla/show_bug.cgi?id=203820

Note that FX project auto-update functionality has not been implemented yet as 7.1(final) is considered the first version with supported FX2.0+ project format. For NB 7.2 it is planned to supply the project update mechanism according to NB standards. The task for it is
http://netbeans.org/bugzilla/show_bug.cgi?id=204765

For the specific situation between 7.1beta and 7.1final we apologize for the inconvenience, but the only reliable thing to do is to regenerate projects in 7.1final when it becomes available.
Comment 4 Marian Mirilovic 2011-11-18 17:51:33 UTC
agree - verified
Comment 5 Petr Somol 2012-01-04 09:19:07 UTC
*** Bug 206842 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo