Bug 206842 - Missing library: libmat.dylib
Missing library: libmat.dylib
Status: RESOLVED DUPLICATE of bug 205249
Product: javafx
Classification: Unclassified
Component: Deployment
7.1
PC Mac OS X
: P4 (vote)
: TBD
Assigned To: Petr Somol
issues@javafx
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-02 15:06 UTC by JAvila
Modified: 2012-01-04 09:19 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description JAvila 2012-01-02 15:06:20 UTC
In upgrading from NetBeans 7.1 beta to 7.1 RC2, my project (using JavaFX), which was working before, now will not even load. The error message is:

Exception in thread "main" java.lang.RuntimeException: java.lang.UnsatisfiedLinkError: Can't load library: /Users/avila/NetBeansProjects/BetaThalDBApp/lib/../bin/libmat.dylib

The named library is nowhere in the distribution of 7.1 RC2.

Where is this request coming from? Is there a work-around?
Comment 1 Petr Somol 2012-01-04 09:19:07 UTC
Unfortunately the FX project build scripts had to be modified between 7.1beta and 7.1rc/final. 7.1beta projects thus may not work properly in 7.1rc/final. For details why this has happened please see

http://netbeans.org/bugzilla/show_bug.cgi?id=205249#c3

For the specific situation of 7.1beta and 7.1final FX project interoperability we apologize for the inconvenience, but the only reliable thing to do is to regenerate projects in 7.1final when it becomes available.

*** This bug has been marked as a duplicate of bug 205249 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo