Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 204810 - [71cat] IllegalArgumentException: C:\Users\Mark\Documents\NetBeansProjects\JavaApplication75\src\javaapplication74\JavaApplication7.java@e5f442dd:1baeab2 is not inside C:\Users\Mark\Documents\NetBeansProjects
[71cat] IllegalArgumentException: C:\Users\Mark\Documents\NetBeansProjects\Ja...
Status: RESOLVED DUPLICATE of bug 157361
Product: projects
Classification: Unclassified
Component: Generic Infrastructure
7.1
All All
: P3 (vote)
: TBD
Assigned To: Jesse Glick
issues@projects
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-08 04:20 UTC by MackSix
Modified: 2011-11-08 20:41 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (3.56 KB, text/plain)
2011-11-08 04:20 UTC, MackSix
Details

Note You need to log in before you can comment on or make changes to this bug.
Description MackSix 2011-11-08 04:20:11 UTC
This bug was originally marked as duplicate of bug 157361, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE Dev (Build 201111070600)
VM: Java HotSpot(TM) Client VM, 21.1-b02, Java(TM) SE Runtime Environment, 1.7.0_01-b08
OS: Windows Vista

User Comments:
MackSix: Renaming a project for the second time after other exceptions occured related to renaming it the first time.




Stacktrace: 
java.lang.IllegalArgumentException: C:\Users\Mark\Documents\NetBeansProjects\JavaApplication75\src\javaapplication74\JavaApplication7.java@e5f442dd:1baeab2 is not inside C:\Users\Mark\Documents\NetBeansProjects\JavaApplication75\src@e76f7583:1d37976
   at org.netbeans.spi.project.support.ant.SourcesHelper$SourceRoot$Group.contains(SourcesHelper.java:203)
   at org.netbeans.spi.java.project.support.ui.PackageViewChildren$NoFoldersDataFilter.acceptFileObject(PackageViewChildren.java:1232)
   at org.openide.loaders.FolderChildren$1R.run(FolderChildren.java:174)
   at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1411)
   at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:1991)
Comment 1 MackSix 2011-11-08 04:20:14 UTC
Created attachment 112974 [details]
stacktrace
Comment 2 MackSix 2011-11-08 18:26:59 UTC
Video of bug. It is the 4th exception at point 5:00 on the video.

http://youtu.be/lSIlBwTd8_E

The 1st exception is bug id #204243. The 2nd exception is bug id #204242 and
the 3rd exception is similar to #204809
Comment 3 Jesse Glick 2011-11-08 20:41:09 UTC

*** This bug has been marked as a duplicate of bug 157361 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo