Bug 204441 - Implement Move Method
Implement Move Method
Status: RESOLVED FIXED
Product: java
Classification: Unclassified
Component: Refactoring
7.1
All All
: P3 with 1 vote (vote)
: 7.2
Assigned To: Ralph Ruijs
issues@java
:
: 57767 (view as bug list)
Depends on: 205696
Blocks: 204440
  Show dependency treegraph
 
Reported: 2011-10-31 12:18 UTC by Jan Becicka
Modified: 2012-04-25 08:58 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Becicka 2011-10-31 12:18:56 UTC

    
Comment 1 Quality Engineering 2011-12-08 12:12:11 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/43a6552101d7
User: Ralph Benjamin Ruijs <ralphbenjamin@netbeans.org>
Log: #204441 and #204442
Initial prototype of Move Members Refactoring. Missing features:
- Javadoc
- Generics
- Some ui improvements
- Finding relevant features
- Make static
Comment 2 Quality Engineering 2012-01-05 15:51:20 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/cf41f8f6666e
User: Ralph Benjamin Ruijs <ralphbenjamin@netbeans.org>
Log: #204441 and #204442 UI Change and QA feedback implemented
Comment 3 Quality Engineering 2012-01-07 16:22:32 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/36a1c437d7b8
User: Ralph Benjamin Ruijs <ralphbenjamin@netbeans.org>
Log: #204441 and #204442 Javadoc support
Comment 4 Ralph Ruijs 2012-02-08 14:19:46 UTC
http://hg.netbeans.org/jet-main/rev/7366a9a6ccf3
Author:    Ralph Benjamin Ruijs <ralphbenjamin@netbeans.org>
Date:      2012-02-08 15:16
Message:   Issue #204441 - Implement Move Method
Comment 5 Ralph Ruijs 2012-04-25 08:58:20 UTC
*** Bug 57767 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo