Bug 57767 - Move Method Refactoring
Move Method Refactoring
Status: RESOLVED DUPLICATE of bug 204441
Product: editor
Classification: Unclassified
Component: Refactoring
4.x
All All
: P2 with 11 votes (vote)
: 7.2
Assigned To: Jan Becicka
issues@java
http://refactoring.netbeans.org/refac...
:
: 57221 74881 98871 125576 130499 150003 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-12 13:29 UTC by Daniel Prusa
Modified: 2012-04-25 08:58 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Prusa 2005-04-12 13:29:37 UTC
This issue tracks implementation of Move Method refactoring.
Comment 1 Jan Becicka 2005-05-20 09:30:02 UTC
*** Issue 57221 has been marked as a duplicate of this issue. ***
Comment 2 Jan Pokorsky 2008-10-16 12:59:25 UTC
*** Issue 150003 has been marked as a duplicate of this issue. ***
Comment 3 Jan Pokorsky 2008-10-16 15:48:27 UTC
*** Issue 74881 has been marked as a duplicate of this issue. ***
Comment 4 Jan Pokorsky 2008-10-16 18:29:22 UTC
*** Issue 98871 has been marked as a duplicate of this issue. ***
Comment 5 Jan Pokorsky 2008-10-16 18:53:22 UTC
*** Issue 125576 has been marked as a duplicate of this issue. ***
Comment 6 Jan Pokorsky 2008-10-16 19:28:10 UTC
*** Issue 130499 has been marked as a duplicate of this issue. ***
Comment 7 fommil 2008-10-16 20:23:33 UTC
ok, there have now been 6 reports for this feature from Netbeans 4.1 to Netbeans 6.5, which completely outweighs the votes (which I know is stupidly used as 
a metric when deciding what to fix)... so should we expect any attention toward this anytime soon?
Comment 8 Jan Pokorsky 2008-10-16 20:47:44 UTC
fommil: I have been going through refactoring features, enhancements and tasks to collect what seems to be important for
users. And yes this feature appears to be very important. Unfortunately, I cannot yet guarantee whether there will be
free resources to implement it to 7.0. In case you would like to volunteer to work on this you are surely welcome!
Comment 9 fommil 2008-10-16 21:01:30 UTC
@jpokorsky I've actually volunteered several times in the past to help out with some features (specifically in the java hints component)... but nobody has ever 
got back to point me in the right direction. Obviously the NetBeans codebase is a monster. If you could help point me in the direction of trunk svn access, the 
build system and the relevant classes, I could have a look... although I must admit, I don't have much free time these days and the little time I do have is 
going into an OSS project.
Comment 10 David Konecny 2008-10-16 22:54:20 UTC
It would be great to have a Wiki page describing how to write and add a new refactoring so that people willing to help
can help.
Comment 11 Jan Pokorsky 2008-10-17 17:38:14 UTC
Here are some useful resources:
* http://wiki.netbeans.org/NetBeansDeveloperFAQ - especially Getting Started section that describes how to get sources
via Mercurial, links to NetBeans API javadocs, how to build NetBeans and modules and many other tips
* http://wiki.netbeans.org/Java_DevelopersGuide - describes how to access java model
* http://wiki.netbeans.org/RefactoringFAQ - describes most common usages
* http://refactoring.netbeans.org/refactorings/devguide.html - a bit out-dated but still useful
* http://refactoring.netbeans.org/refactorings/movemethod.html - Move Method Refactoring Specification
* http://wiki.netbeans.org/NetBeansUserFAQ#section-NetBeansUserFAQ-ContributorAgreement - this is important to read and
sign if you decide to contribute some code to hg.netbeans.org repository.

The NetBeans source base is really huge but it is a modular system so it is not necessary to know everything. You can
find inspiration especially in the refactoring.java module.

In case you have more questions feel free to ask even on my email.
Comment 12 fommil 2008-10-19 12:24:40 UTC
Excellent! That's an invaluable resource... I'll have a look. Must admit though, I have a few bug reports and feature requests that I'd rather fix than this one ;-)
Comment 13 Ralph Ruijs 2012-04-25 08:58:20 UTC

*** This bug has been marked as a duplicate of bug 204441 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo