Bug 204227 - When HTML Completion Offers End Tags After Less Than Character option is enabled and used the previous character gets deleted
When HTML Completion Offers End Tags After Less Than Character option is enab...
Status: VERIFIED FIXED
Product: web
Classification: Unclassified
Component: HTML Editor
7.0.1
PC Windows 7 x64
: P2 (vote)
: 7.1
Assigned To: Marek Fukala
issues@javaee
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-25 16:13 UTC by mikerowe81
Modified: 2011-12-01 17:06 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mikerowe81 2011-10-25 16:13:55 UTC
With the following option enabled:
Options -> Editor -> Code Completion -> Language: HTML -> Completion Offers End Tags After Less Than (<) Character

If I am working on some HTML and as an example have the following text:

<p>abc<

Entering that final Less Than (<) brings up the autocomplete menu as it should and the first option is </p>, which is what I want, but when I press enter I get the following result:

<p>ab</p>

Notice that the "c" has been deleted. I get this error for any end tag that I complete in this way.

Product Version = NetBeans IDE 7.0.1 (Build 201107282000)
Operating System = Windows 7 version 6.1 running on amd64
Java; VM; Vendor = 1.6.0_20
Runtime = Java HotSpot(TM) 64-Bit Server VM 16.3-b01
Comment 1 Marek Fukala 2011-10-26 14:31:45 UTC
hmm really ugly, reproducible. Likely not spot earlier since not many people enable the option "add end tags after < char" in the preferences.
Comment 2 Marek Fukala 2011-10-26 15:14:13 UTC
fixed in web-main#efdb57f05e71
Comment 3 Quality Engineering 2011-10-27 14:05:14 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/efdb57f05e71
User: Marek Fukala <mfukala@netbeans.org>
Log: #204227 - When HTML Completion Offers End Tags After Less Than Character option is enabled and used the previous character gets deleted
Comment 4 Vladimir Riha 2011-12-01 17:06:20 UTC
verified


Product Version: NetBeans IDE 7.1 RC2 (Build 201111302200)
Java: 1.7.0_02; Java HotSpot(TM) Client VM 22.0-b10
System: Linux version 3.0.0-13-generic-pae running on i386; UTF-8; en_US (nb)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo