Bug 203545 - Add dotted line to show code tree depth in editor
Add dotted line to show code tree depth in editor
Status: RESOLVED DUPLICATE of bug 182513
Product: editor
Classification: Unclassified
Component: Formatting & Indentation
-S1S-
All Windows XP
: P4 with 10 votes (vote)
: 7.2
Assigned To: Milutin Kristofic
issues@editor
: PLAN, USABILITY
: 207528 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-11 18:08 UTC by fernandojmartin
Modified: 2012-09-22 23:25 UTC (History)
6 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments
Screenshot of how IntelliJ IDEA 11 does it (64.69 KB, image/png)
2012-01-22 20:56 UTC, rdelaplante
Details

Note You need to log in before you can comment on or make changes to this bug.
Description fernandojmartin 2011-10-11 18:08:01 UTC
I'd love to have a dotted/dashed vertical line like in, for instance, Notepadd++ (http://17of26.com/wp-content/uploads/2009/10/notepad++.png) showing the tree depth of the code.

In the image (I Googled for it) there's HTML but the same happens with PHP and other languages.
Even brace highlighting is a great visual aid, havind the tree depth is fantastic to instantly recognize the depth or find the matching brace (sometimes wrongly indented accidentally).
Comment 1 Jiri Prox 2012-01-20 06:16:44 UTC
*** Bug 207528 has been marked as a duplicate of this bug. ***
Comment 2 rdelaplante 2012-01-22 20:56:46 UTC
Created attachment 115150 [details]
Screenshot of how IntelliJ IDEA 11 does it
Comment 3 orobardet 2012-07-24 15:12:26 UTC
I second this.
I'm starting to use NetBeans in replacement of Komodo Edit, and I this is one of the feature I need (with block code folding in PHP, for which a ticket is already opened).

It's very usefull in languages with a lot of multi-line alignement is needed, like PHP and especially JS (where a lot of recursive declaration of code is often needed).

Thanks in advance to people who will be able to code and plan this enhancement.
Comment 4 markiewb 2012-09-22 23:25:03 UTC

*** This bug has been marked as a duplicate of bug 182513 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo