Bug 202655 - not all JavaSE plugins activated after manual JavaFX2 activation
not all JavaSE plugins activated after manual JavaFX2 activation
Status: RESOLVED DUPLICATE of bug 202164
Product: javafx
Classification: Unclassified
Component: Platform
7.1
All All
: P4 (vote)
: 7.2
Assigned To: Tomas Zezula
issues@javafx
: ERGONOMICS
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-26 09:09 UTC by Stepan Zebra
Modified: 2014-02-25 17:55 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stepan Zebra 2011-09-26 09:09:23 UTC
Product Version: NetBeans IDE 7.1 Beta (Build 201109252201)
Java: 1.7.0; Java HotSpot(TM) 64-Bit Server VM 21.0-b17
System: Windows 7 version 6.1 running on amd64; Cp1252; en_US (nb)

Use case:
Start fresh IDE.
Invoke the Plugins manager.
Search for JavaFX 2 Support plugin.
Check it and press Activate.
List of required Plugins will be shown.
Complete the activation.

After activating JavaFX2 this way, Hibernate and Spring Beans from JavaSE pack remain deactivated, which is inconsistent with situation, when FX is activated during project creation (complete set of JavaSE plugins activated).

I suggest to adjust the behavior to activate the complete JavaSE pack even in this scenario, to prevent any issues with inconsistency.
Comment 1 Petr Somol 2011-10-27 07:28:49 UTC
possibly related problem:

"when using the "All" NB version the JavaFX is activated only when you try to create new JavaFX project and not if you try to directly go to Java Platforms. "
Comment 2 Anton Chechel 2011-11-02 15:15:07 UTC

*** This bug has been marked as a duplicate of bug 202164 ***
Comment 3 Stepan Zebra 2011-12-06 15:49:39 UTC
Hibernate and Spring Beans are still remaining deactivated in described use case, however there doesn't seems to be any consequence from this situation.
Comment 4 Lou Dasaro 2013-08-03 03:14:12 UTC
Can this be closed as a result of newer versions (7.4) of Netbeans that install with JavaFX Support already (pre-)activated?
Comment 5 Lou Dasaro 2013-08-27 22:34:31 UTC
(In reply to mr_lou_d from comment #4)
> Can this be closed as a result of newer versions (7.4) of Netbeans that
> install with JavaFX Support already (pre-)activated?

I'll answer my own question! As Petr pointed out, JavaFX support isn't pre-activated in the "All" distribution. Therefore, the issue remains...
Comment 6 swpalmer 2014-02-25 02:58:44 UTC
This appears to be the cause of Issue 239895
Comment 7 Lou Dasaro 2014-02-25 17:55:57 UTC
I'm not sure they have the same root cause, perhaps similar. This is actually a different problem from 2011, where activating the main JavaFX 2 plugin in Tools->Plugins->Installed (non-details) needed to more fully activate Java SE. It was a duplicate of Bug 202164, which has since been FIXED. 
Returning to DUPLICATE status to avoid confusion with Bug 239835 
If I'm wrong, I'm sure someone will correct me.

*** This bug has been marked as a duplicate of bug 202164 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo