Bug 202093 - [71cat] Output view does not receive focus when application is running
[71cat] Output view does not receive focus when application is running
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Output Window
7.0.1
PC All
: P2 (vote)
: 7.1
Assigned To: Jaroslav Havlin
issues@platform
: FOCUS
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-14 03:25 UTC by Michel Graciano
Modified: 2011-09-26 15:36 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michel Graciano 2011-09-14 03:25:51 UTC
[ BUILD # : d72f993fdc76 ]
[ JDK VERSION : 1.7 ]

When you run your application and the Output view is minimized it is opened but
not focused, so if you are debugging your application, or even editing, you
have to use shortcuts to editor (Ctrl + 0) or give focus to Output with mouse
and later click again at the editor since most of the time the cursor will
remain at the editor anyway but you can see the editor because the view is not
anymore minimized. It is a critical usability issue. It worked well before 7.0
but was broken sometime during 7.0 release time, probably after NetCAT 7.0
since I can't remember exactly it has started.
Comment 1 Jaroslav Havlin 2011-09-16 13:10:41 UTC
core-main/rev/fcc59c126c40

Caused by fix of bug 160767.
Fixed.
Comment 2 Quality Engineering 2011-09-17 14:14:30 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/fcc59c126c40
User: Jaroslav Havlin <jhavlin@netbeans.org>
Log: #202093 - [71cat] Output view does not receive focus when application is running
Comment 3 Stanislav Aubrecht 2011-09-19 10:19:21 UTC
the problem with minimized output window has been fixed in issue #159356 so i'm not sure this bug fixes is really needed.
Comment 4 Jaroslav Havlin 2011-09-19 12:06:43 UTC
It seems that it is not the same bug and the fix is needed. (I could reproduce the bug with latest sources).
The problem was that when user ran their application, the output window appeared without focus. Then when the users pressed a key, a change could happen (cursor move, a letter typed), but the user was not able to see the change as it was hidden by the output window. 
If the output window has focus, no changes behind the output window are possible.

Do you thing the fix is not correct, or it should be fixed somewhere else?
Comment 5 Michel Graciano 2011-09-19 15:08:06 UTC
v. Build 20110919-e0d2f9bdd78c


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo