Bug 160767 - output window grabs focus when sliding in
output window grabs focus when sliding in
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Output Window
6.x
All All
: P3 (vote)
: 7.0
Assigned To: Martin Entlicher
issues@platform
issue_reviewed
: FOCUS
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-20 20:07 UTC by athompson
Modified: 2011-01-24 17:15 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
the "exception repoter" window is slid in (up) by hovering over the button without clicking. the editor tab 'pom.xml' still has focus. (113.58 KB, image/png)
2009-03-24 15:09 UTC, athompson
Details
! the "output" window is slid in (up) by hovering over the button without clicking. the 'output' window has taken the focus away from the editor tab 'pom.xml', which is wrong. (113.43 KB, image/png)
2009-03-24 15:12 UTC, athompson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description athompson 2009-03-20 20:07:24 UTC
Product Version: NetBeans IDE Dev (Build 200903191401)
Java: 1.6.0_12; Java HotSpot(TM) Client VM 11.2-b01
System: Linux version 2.6.28-11-generic running on i386; UTF-8; en_US (nb)
Userdir: /home/athompson/.netbeans/dev

1. open the output window
2. minimize the window by clicking the 'minimize' button
3! 'slide in' the output window by hovering the mouse over the output button above the status bar.  the panel slides in,
but the window grabs focus so it won't slide back out without manual intervention.
Comment 1 Michael Nazarov 2009-03-23 16:18:21 UTC
Works fine for me. Would you please provide some additional information, may be more detailed steps.
May be special kind of output window should be used, filled by certain output from application or
empty. Any kind or details.
Comment 2 athompson 2009-03-24 15:05:33 UTC
"Would you please provide some additional information"

all other minimized windows remain unfocused when they slide in (up).  this is so that when you move the mouse away they
will automatically slide back out (down), which is quite useful if you quickly want to look it something. the output
window used to work this way, but recently (within the last few months) it doesn't.  it grabs focus when it slides in
(up), which prevents it from sliding back out (down).

"May be special kind of output window should be used, filled by certain output from application or empty."

i'm not sure what you mean.  this is about the focus; the content of the window makes no difference to me.
Comment 3 athompson 2009-03-24 15:09:28 UTC
Created attachment 78755 [details]
the "exception repoter" window is slid in (up) by hovering over the button without clicking.  the editor tab  'pom.xml' still has focus.
Comment 4 athompson 2009-03-24 15:12:17 UTC
Created attachment 78756 [details]
! the "output" window is slid in (up) by hovering over the button without clicking.  the 'output' window has taken the focus away from the editor tab  'pom.xml', which is wrong.
Comment 5 Michael Nazarov 2009-03-26 08:49:32 UTC
Product Version: NetBeans IDE Dev (Build 200903250219)
Java: 1.6.0_13; Java HotSpot(TM) Client VM 11.3-b02
System: Windows XP version 5.1 running on x86; Cp1251; ru_RU (nb)

Reproduced.
Comment 6 athompson 2009-04-17 18:46:22 UTC
should the component still be 'IDE'?
Comment 7 athompson 2009-06-27 06:24:19 UTC
i know this doesn't sound like a major problem if you don't use slide-in windows, but if you do it's VERY annoying
because it breaks your concentration.  first, it covers up your code, then you're wondering why the window isn't going
away on its own like all the other windows, then you have take your eyes off (what's left of) your code to move your
mouse to the button and click.

please, it shouldn't be a major endeavour.  can this get taken care of before the release?
Comment 8 Stanislav Aubrecht 2009-12-04 09:16:43 UTC
it's probably too late for 6.8 fix now
cc'ing tomas who might a bit more about this issue
Comment 9 Stanislav Aubrecht 2010-09-14 14:17:53 UTC
it's output window problem, all other sliding windows behave correctly
Comment 10 Martin Entlicher 2011-01-20 16:27:23 UTC
Caused by the fix of issue #159356.
Comment 11 Martin Entlicher 2011-01-21 14:40:07 UTC
The strange fix of issue #159356 was reverted by changeset: 186908:f4db7d9ea9a7
http://hg.netbeans.org/main/rev/f4db7d9ea9a7
It solves this issue.
Comment 12 Quality Engineering 2011-01-22 06:15:15 UTC
Integrated into 'main-golden', will be available in build *201101220001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/f4db7d9ea9a7
User: mentlicher@netbeans.org
Log: #160767 It's wrong to activate window that was just made visible only. Revert of changeset 9e60d3d80021 made as a fix of issue #159356.
Comment 13 athompson 2011-01-24 17:15:55 UTC
yup.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo