Bug 201486 - Focus is not transferred to Members/Hierarchy View
Focus is not transferred to Members/Hierarchy View
Status: VERIFIED FIXED
Product: java
Classification: Unclassified
Component: Navigation
7.1
PC Windows XP
: P2 with 3 votes (vote)
: 7.1.2
Assigned To: Tomas Zezula
issues@java
71patch2-verified
: FOCUS, REGRESSION
: 203442 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-31 12:59 UTC by Jiri Prox
Modified: 2012-04-06 12:06 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Prox 2011-08-31 12:59:54 UTC
When opening Members or Hierarchy View (alt-F12 and ctrl-F12) the focus is not transferred to the newly opened window and stays in the editor, below the window. 



Product Version: NetBeans IDE Dev (Build 20110831-adb22779b766)
Java: 1.7.0; Java HotSpot(TM) Client VM 21.0-b17
System: Windows 7 version 6.1 running on x86; Cp1252; en_US (nb)
User directory: C:\Users\jprox\.netbeans\dev
Cache directory: C:\Users\jprox\.netbeans\dev\var\cache
Comment 1 Jiri Prox 2011-10-12 07:41:04 UTC
*** Bug 203442 has been marked as a duplicate of this bug. ***
Comment 2 stefan79 2011-12-07 13:31:27 UTC
Some Info else: 
-) Text is written into Find - Textfield

Steps to reproduce:
-) Open a Java-File -> Set Focus into editor
-) Press Ctrl-F12
-) Type in some text "xyz"
-) The text "xyz" is written into search Text-Field

-
Is this really a P3-Bug?
I think this is a P2.
Comment 3 tomzi 2011-12-14 10:16:38 UTC
This is really annoying since this used to work just fine, this should be changed to REGRESSION
Comment 4 stefan79 2012-03-05 12:13:50 UTC
P2->3 (-> NetCat-Mail)
Comment 5 Tomas Zezula 2012-03-12 18:40:25 UTC
Works fine on Mac both Dev and 7.1
Reproduceable on Win XP on VirtualBox.
Comment 6 Tomas Zezula 2012-03-13 15:36:42 UTC
Fixed jet-main 05f5188539fe
Comment 7 Quality Engineering 2012-03-17 10:40:42 UTC
Integrated into 'main-golden', will be available in build *201203170400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/05f5188539fe
User: Tomas Zezula <tzezula@netbeans.org>
Log: #201486:Focus is not transferred to Members/Hierarchy View
Comment 8 stefan79 2012-03-21 07:13:35 UTC
Can you put this in 7.1.2?

Reason: I will make a rollout at work (~25 Pc´s are currently at 6.9), but with this bug I´ll wait because we need this feature very often.
Comment 9 Jiri Prox 2012-03-21 07:32:06 UTC
verified and marking as patch candidate
Comment 10 stefan79 2012-03-21 07:32:50 UTC
Thanks!
Comment 11 Marian Mirilovic 2012-03-22 12:26:23 UTC
Tomas, 
please proceed with integration into release71_fixes branch and follow http://wiki.netbeans.org/NetBeansPatchesProcess . Thanks in advance.
Comment 12 Tomas Zezula 2012-04-04 09:00:27 UTC
Transplanted into release71_fixes 7796996b02e7, d447e208b9e6
Comment 13 Quality Engineering 2012-04-05 01:20:12 UTC
Integrated into 'releases', will be available in build *201204042205* or newer. Wait for official and publicly available build.
Changeset: http://hg.netbeans.org/releases/rev/7796996b02e7
User: Tomas Zezula <tzezula@netbeans.org>
Log: #201486:Focus is not transferred to Members/Hierarchy View
Comment 14 Jiri Prox 2012-04-06 12:06:35 UTC
verified


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo