Bug 198963 - Netbeans 7 loading stuck at "Done loading modules."
Netbeans 7 loading stuck at "Done loading modules."
Status: RESOLVED DUPLICATE of bug 199538
Product: python
Classification: Unclassified
Component: Platform
7.0
PC Linux
: P2 with 3 votes (vote)
: TBD
Assigned To: ardavis26
issues@python
: RANDOM
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-28 01:23 UTC by occulens
Modified: 2012-10-05 12:35 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
error message after upgrade (8.03 KB, application/octet-stream)
2012-10-05 12:35 UTC, e_web_le
Details

Note You need to log in before you can comment on or make changes to this bug.
Description occulens 2011-05-28 01:23:13 UTC
Background:
Installed Netbeans 7.0 (PHP version)

Installed the python plugin. (had to use this link: http://deadlock.netbeans.org/hudson/job/nbms-and-javadoc/lastStableBuild/artifact/nbbuild/nbms/updates.xml.gz )

Symptoms:
When launching Netbeans 7.0, it often (but not always) hangs on "Done loading modules."

I don't know if this is a problem with Netbeans 7.0 or the python plugin.

Thanks!
Comment 1 lordtakuban 2011-06-20 11:44:33 UTC
I experienced the same issue after doing a set of updates this morning.  I do not have the Python plugin installed.  Running Windows 7 Corporate 64-bit.
Comment 2 aLFie_ 2011-06-21 07:32:53 UTC
Same problem here, after i have updated the existing php smarty framework plugin. 

MBP 2011 Mac OS X Version 10.6.7 (Intel Core i7)
Comment 3 lordtakuban 2011-06-21 11:34:16 UTC
Smarty plugin might be the key.  I have that plugin as well.  I'll see if I can remove that plugin manually somehow without Netbeans running.  I've been using 6.9.1 in the mean time to get things done.
Comment 4 mixto 2011-06-21 12:17:31 UTC
Confirm... Smarty plugin IS the key! Osx 10.6.7 core 2 duo.

How I can remove manually?
Comment 5 lordtakuban 2011-06-21 12:51:45 UTC
(In reply to comment #4)
> Confirm... Smarty plugin IS the key! Osx 10.6.7 core 2 duo.
> 
> How I can remove manually?

I don't know.  I haven't been able to find any files related to the Smarty framework plugin.  Hopefully, someone else knows how or what the problem might be if it's not the Smarty framework plugin.
Comment 6 katsuke 2011-06-22 15:33:02 UTC
Simple fix until the module is fixed:

From: http://blogs.oracle.com/gridbag/entry/disabling_a_netbeans_plugin_before

Modify:

C:\Users\your_user\.netbeans\7.0\config\Modules\org-netbeans-modules-php-smarty.xml

Line 7 to false:

 <param name="enabled">true</param>

After that it loaded fine. Hope that helps.
Comment 7 lordtakuban 2011-06-22 19:08:56 UTC
(In reply to comment #6)
> Simple fix until the module is fixed:
> ...

That worked great.  Thanks for the fix and info.
Comment 8 rlorenzo 2011-06-25 01:41:17 UTC
Seems the problem is fixed in issue 199538.

*** This bug has been marked as a duplicate of bug 199538 ***
Comment 9 e_web_le 2012-10-05 12:35:01 UTC
Created attachment 125450 [details]
error message after upgrade


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo