Bug 199538 - Updated PHP Smarty Framework addon breaks Netbeans
Updated PHP Smarty Framework addon breaks Netbeans
Status: RESOLVED FIXED
Product: php
Classification: Unclassified
Component: Smarty
7.0
PC Linux
: P1 with 2 votes (vote)
: 7.0
Assigned To: Martin Fousek
issues@php
:
: 198963 199536 199577 199942 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-20 08:53 UTC by MrDutchy
Modified: 2011-09-06 10:39 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
message.log (26.74 KB, text/plain)
2011-07-07 05:44 UTC, nakp
Details
jvm dump (20.29 KB, text/plain)
2011-07-07 06:14 UTC, nakp
Details
smarty 1.50.2 nbm (67.55 KB, application/octet-stream)
2011-07-07 18:51 UTC, Martin Fousek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description MrDutchy 2011-06-20 08:53:56 UTC
After the recent update to 1.50.1 Netbeans would not finish loading.

I had to disable it completely by editing

C:\Users\myusr\.netbeans\7.0\config\Modules\org-netbeans-modules-php-smarty.xml

And changing the attribute called "enabled" from true to false
Comment 1 Martin Fousek 2011-06-21 06:26:29 UTC
Confirmed, there are perhaps bad dependencies although it doesn't looks so. I removed verification for 1.50.1 plugin to not update it automatically to all users and I will fix it this week.

Thank you a lot for reporting that...
Comment 2 Martin Fousek 2011-06-21 12:53:56 UTC
*** Bug 199577 has been marked as a duplicate of this bug. ***
Comment 3 Martin Fousek 2011-06-21 13:49:45 UTC
Should be fixed by this changeset:
http://hg.netbeans.org/main/contrib/rev/bce3697ad52a

Sorry for your troubles. I'm afraid that you have to download another IDE (the userdir should work perhaps the same). On the UC will appear new Smarty plugin during today. So when you would have 1.50.1 offered in the IDE again, it should be already fixed there. If you would be facing any troubles let me know, thanks again.
Comment 4 Martin Fousek 2011-06-21 19:09:14 UTC
Sorry, another option for fixing your IDE would be uninstallation and reinstalation of PHP plugins. BTW, the new, fixed Smarty plugin was published on UC - it isn't just automatically offered in IDE for now, but it should be during tomorrow.
Comment 5 aperitero 2011-06-23 10:58:42 UTC
We had the same bug here and observed that NetBeans will finish loading correctly when the start page is enabled (help > start page > show on startup)!
Comment 6 rlorenzo 2011-06-25 01:41:17 UTC
*** Bug 198963 has been marked as a duplicate of this bug. ***
Comment 7 nakp 2011-06-26 03:09:14 UTC
Same problem in linux, actually using with lastest version of all (NB recieved a few updates) (I used the install.sh way instead .deb package in Linux Mint 11)

It works enabling the plugin after loading NetBeans, but the first time I re-launched NB it appeared disabled, second time same issue as this bug, NB doesn't finish loading anymore, I had to manually disable it to launch NB.
Comment 8 qqqpqpp 2011-06-27 15:33:42 UTC
Still doesn't work with a new installation of Netbeans 7.0 and a new userdir. Is there a way to get the previous version of the plugin to get things work until there's a real solution to the problem?
Comment 9 jason37 2011-06-30 21:37:51 UTC
Same issue here with this config:

Product Version: NetBeans IDE 7.0 (Build 201104080000)
Java: 1.6.0_24; Java HotSpot(TM) 64-Bit Server VM 19.1-b02-334
System: Mac OS X version 10.6.8 running on x86_64; MacRoman; en_US (nb)
Comment 10 Martin Fousek 2011-07-04 06:56:32 UTC
*** Bug 199536 has been marked as a duplicate of this bug. ***
Comment 11 Martin Fousek 2011-07-04 07:07:25 UTC
Sorry guys, could you send me your exact steps? I tried following without facing this issue again:
1, downloaded nb70 from nb.org
2, started as ./netbeans --userdir /tmp/ud1
3, reloaded catalog of plugins and installed Smarty PHP Framework plugin
4, opened several project with and also without Smarty files
-> any another start/restart of IDE doesn't break it

Please let me know where are your steps different. 

Thanks a lot. Also please attach your messages log and thread dump if you can:
http://wiki.netbeans.org/GenerateThreadDump
http://wiki.netbeans.org/FaqLogMessagesFile
Comment 12 nakp 2011-07-05 05:59:46 UTC
did you update the whole netbeans before installing the plugin? I have the PHP version with all up to date
Comment 13 tlc 2011-07-05 12:55:40 UTC
(In reply to comment #5)
> We had the same bug here and observed that NetBeans will finish loading
> correctly when the start page is enabled (help > start page > show on startup)!

Same here, enable start page show on startup, ide doesn't hang on restart. I have nb7 php ide, with smarty plugin, everything is up to date. 

Not sure if it helps but if I delete the C:\Users\<username>\.netbeans\7.0\config\Windows2Local folder, ide will restart without start page show on startup enabled, but then ide starts in original default configuration. All ide customizations (window placements etc.) are lost.
Comment 14 Martin Fousek 2011-07-07 05:29:41 UTC
It seems that the issue doesn't happen to anybody now. I'm really not able to reproduce and I haven't enough of information for finding out what's wrong there. 

Please could anybody write steps or attach messages.log + thread dump? I really would like to fix that so please help me with that a little bit, thanks. BTW, feel free to contact me to email address marfous@netbeans.org.
Comment 15 nakp 2011-07-07 05:44:52 UTC
Created attachment 109282 [details]
message.log
Comment 16 nakp 2011-07-07 05:51:02 UTC
* Install Netbeans from the webpage (not a distro package)
* Update all Netbeans stuff (mandatory, or bug doesn't come up)
* Install Smarty plugin, I have a PHP project already open and everything works fine until I restart netbeans

In my case I have an open php project every time I start Netbeans, startup page doesn't seem to have any effect (shown or not at start up, it's always the same)

Disabling Smarty plugin makes NB start normally

my message.log has a lot of extra plugins which I recently installed but it would be the same if I only had netbeans-php + smarty (trust me, I though it was a subversion bug)
Comment 17 Martin Fousek 2011-07-07 06:03:37 UTC
Thanks nakp for these information. The messages.log shows that you have correct version of the smarty plugin - I trust you that it's smarty issue.

I tried the same steps today:
1, downloaded netbeans-php-70.zip -> unpacked
2, started IDE, updated all plugins, restart IDE
3, installed Smarty plugin, opened several PHP projects (with and without .tpls)
-> restart of the IDE still not lead to your troubles :/

Could you nakp try out if it's specific project related? Means could you close all your project and create some new one i.e. with one .tpl file? Please let me know if it happens as well then. 

BTW, I suppose that you aren't getting message about turning off any modules but your IDE "just" freeze in the phase "Done loading modules", right?
Comment 18 nakp 2011-07-07 06:14:53 UTC
Created attachment 109283 [details]
jvm dump
Comment 19 nakp 2011-07-07 06:16:35 UTC
Hi, I tried starting NB with only 1 (new) PHP project without any tpl file and it happened. I've attached the dump
Comment 20 Martin Fousek 2011-07-07 06:24:57 UTC
Thanks. As I mentioned, not able to reproduce but it should be fixable on base of your dump - it seems that there is a deadlock. I need some time for investigation/fixing and then (during today) I would publish here .nbm if you could try it if it will help.
Comment 21 nakp 2011-07-07 06:32:27 UTC
Of course! I'd be more than glad to try it as I really really use it a lot, by the time I have to load and unload the plugin every startup hehe

BTW, I use the .sh instead of the zip, but I don't think it's a permission issue as everything goes to .netbeans folder
Comment 22 Martin Fousek 2011-07-07 18:51:01 UTC
Created attachment 109300 [details]
smarty 1.50.2 nbm

Ok, so could you give it a try? I should help, but I would need to have that confirmed - I'm not able to check myself. It's version 1.50.2 and if it would help, let me know please and I will let update plugin on the plugin portal.

Thanks for your help.
Comment 23 Martin Fousek 2011-07-07 18:54:23 UTC
*** Bug 199942 has been marked as a duplicate of this bug. ***
Comment 24 nakp 2011-07-07 21:02:27 UTC
Hello Martin, it works perfect!!! thank you so much! I tried with several projects with tpl and works fine :) I may close this but maybe we need someone testing with mac and windows (let me call my friends xD)
Comment 25 Martin Fousek 2011-07-07 21:18:43 UTC
That's just great. Let's wait if could somebody confirm. Don't close this issue please, just leave a comment if you will have chance to test it more. 

I will push changes into repositories and then close that then. Tomorrow I will update plugin on UC with the newer one (it means that it could be on UC in few days).
Comment 26 om 2011-07-08 05:17:14 UTC
+1
1.50.2 fixes on Windoze as well. Good work!
Comment 27 Martin Fousek 2011-07-08 08:56:28 UTC
Ok, closing as fixed in trunk:
http://hg.netbeans.org/main/contrib/rev/70949fcf86f2

and in the release70 branch as well: 
http://hg.netbeans.org/main/contrib/rev/10ffafd12a23

Smarty Plugin on Plugin Portal is updated and it will appears on UC during several days.
Comment 28 Quality Engineering 2011-08-27 14:14:55 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/b18369f81f64
User: Martin Fousek <marfous@netbeans.org>
Log: #199538 - Updated PHP Smarty Framework addon breaks Netbeans


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo