Bug 198493 - Compilation Error messages in the output window for Maven projects don't go the source file when clicked.
Compilation Error messages in the output window for Maven projects don't go t...
Status: RESOLVED DUPLICATE of bug 197381
Product: projects
Classification: Unclassified
Component: Maven
7.0
All All
: P3 (vote)
: 7.0
Assigned To: Jesse Glick
issues@projects
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-10 20:00 UTC by swpalmer
Modified: 2011-05-16 08:04 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description swpalmer 2011-05-10 20:00:33 UTC
Product Version = NetBeans IDE 7.0 (Build 201104080000)
Operating System = Windows XP version 5.1 running on x86
Java; VM; Vendor = 1.6.0_25
Runtime = Java HotSpot(TM) Server VM 20.0-b11

E.g.:

[compiler:compile]
Compiling 399 source files to D:\Personal\MyProject\target\classes
-------------------------------------------------------------
COMPILATION ERROR : 
-------------------------------------------------------------
\Personal\MyProject\src\main\java\my\package\MyClass.java:[19,23] package org.junit does not exist
\Personal\MyProject\src\main\java\my\package\MyClass.java:[55,4] cannot find symbol
symbol: method fail(java.lang.String)
				fail((String)errorMessage);
2 errors 
-------------------------------------------------------------
------------------------------------------------------------------------
BUILD FAILURE

Note that I am running on Windows (backslashes used as path separators), but there is no drive letter insanity in the path shown.
Comment 1 swpalmer 2011-05-10 20:01:12 UTC
Clicking on the error line (which is shown as a hyperlink) produces a beep and nothing more.
Comment 2 Marian Mirilovic 2011-05-16 08:04:59 UTC

*** This bug has been marked as a duplicate of bug 197381 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo