Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 198001 - Allow submitting separate versions of plugins per NetBeans releases
Allow submitting separate versions of plugins per NetBeans releases
Status: VERIFIED FIXED
Product: updatecenters
Classification: Unclassified
Component: Pluginportal
7.0
All All
: P1 (vote)
: TBD
Assigned To: Jan Pirek
issues@updatecenters
:
: 124376 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-22 13:06 UTC by Petr Jiricka
Modified: 2012-06-27 06:49 UTC (History)
3 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Jiricka 2011-04-22 13:06:48 UTC
Currently the Plugin Portal keeps track of just one revision of a plugin, so it is impossible to have distinct version for separate NetBeans releases. It would be useful to specify a NetBeans version when uploading a new revision of the plugin, and this would keep the same plugin revisions for other NetBeans versions.

This change would also require a change of the Download button - the user would need to specify which NetBeans version they are using. This could be done by changing the label of the Download button to something like "Download for NetBeans 7.0" and there would also be a small link "Other NetBeans releases" that would provide access to download for other releases.
Comment 1 Jiri Kovalsky 2011-04-26 13:42:48 UTC
I agree this would be handy. Raising priority since I have heard of it from more sources. The download button could download version selected in a combo box above it.
Comment 2 err 2011-05-06 13:51:24 UTC
This versioning issue is why I stopped using the plugin portal for any distribution; though it serves to "advertise" jVi.

I'm getting ready to publish a module that only serves to install an update center, that's essentially a workaround for
Bug 106350 - plugin doesn't appear in update center
I'm glad there will finally be "built-in" access to jVi. (I should have tried it a long time ago; I didn't think I could put the update center in the sourceforge file release system and have everything, including statistics, just work)

But first I'm finishing a workaround for
bug 198359 - removed UC can not be added (re-added) by installing a module
Comment 3 err 2011-05-06 14:04:37 UTC
BTW, I suppose you've seen the proposal Jesse is working on: http://wiki.netbeans.org/AggregatingUC

which could handle the zip file issue.
Comment 4 Jiri Kovalsky 2012-01-02 13:41:17 UTC
*** Bug 124376 has been marked as a duplicate of this bug. ***
Comment 5 Jiri Kovalsky 2012-01-02 15:27:16 UTC
This is the highest priority feature for Plugin Portal 2.1. Honzo, can we meet to design it anytime soon?
Comment 6 Jan Pirek 2012-06-26 14:03:16 UTC
this is now deployed
Comment 7 Jiri Kovalsky 2012-06-27 06:49:25 UTC
Works correctly so far. Verified.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo