Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 197710 - LowPerformance took 3139 ms.
LowPerformance took 3139 ms.
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: Painting & Printing
7.1
All All
: P3 (vote)
: 7.2
Assigned To: Miloslav Metelka
issues@editor
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-13 15:01 UTC by davideconsonni
Modified: 2012-06-21 22:44 UTC (History)
34 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (24.26 KB, application/nps)
2011-04-13 15:01 UTC, davideconsonni
Details
nps snapshot (130.65 KB, application/nps)
2011-07-04 03:40 UTC, Exceptions Reporter
Details
nps snapshot (205.67 KB, application/nps)
2011-07-05 05:25 UTC, Peter Nabbefeld
Details
dump during and after slowness (94.61 KB, text/plain)
2011-12-14 08:28 UTC, muellermi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description davideconsonni 2011-04-13 15:01:04 UTC
This bug was originally marked as duplicate of bug 180595, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE Dev (Build 201104100401)
VM: Java HotSpot(TM) Client VM, 16.3-b01, Java(TM) SE Runtime Environment, 1.6.0_20-b02
OS: Windows 7

User Comments:
davideconsonni: opening ide



Maximum slowness yet reported was 3139 ms, average is 3139
Comment 1 davideconsonni 2011-04-13 15:01:09 UTC
Created attachment 107723 [details]
nps snapshot
Comment 2 Exceptions Reporter 2011-07-04 03:40:49 UTC
Created attachment 109221 [details]
nps snapshot

at netbeans start proyect scanning
Comment 3 Peter Nabbefeld 2011-07-05 05:25:47 UTC
Created attachment 109230 [details]
nps snapshot
Comment 4 muellermi 2011-12-14 08:27:52 UTC
Today, it took 20s, see  id #551151.
I took a dump during and after this slowness.
Comment 5 muellermi 2011-12-14 08:28:00 UTC
Created attachment 114127 [details]
dump during and after slowness
Comment 6 Antonin Nebuzelsky 2011-12-28 18:15:30 UTC
-> editor
Comment 7 Miloslav Metelka 2012-06-07 08:28:36 UTC
Partially solved by 194965 (MainMenuAction.setMenu() getting info from MimeLookup is now rescheduled from AWT).
Also AlwaysEnabledAction$CheckBox.isPreferencesSelected() leads to calling EditorActionUtilities.getGlobalPreferences() which is slow since it reads from MimeLookup. I have added the call into editor's warmup.

http://hg.netbeans.org/jet-main/rev/212de82acad6
Comment 8 Quality Engineering 2012-06-08 06:11:35 UTC
Integrated into 'main-golden', will be available in build *201206080001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/212de82acad6
User: Miloslav Metelka <mmetelka@netbeans.org>
Log: #197710 - LowPerformance took 3139 ms - slow EditorActionUtilities.getGlobalPreferences().


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo