Bug 180595 - 26s in goto oposite action
26s in goto oposite action
Status: RESOLVED FIXED
Product: utilities
Classification: Unclassified
Component: Test Runner
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Alexei Mokeev
issues@utilities
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
: 171097 179046 181320 182078 183853 (view as bug list)
Depends on:
Blocks: 176506
  Show dependency treegraph
 
Reported: 2010-02-11 03:20 UTC by Exceptions Reporter
Modified: 2010-05-05 10:39 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (256.00 KB, application/nps)
2010-02-11 03:20 UTC, Exceptions Reporter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2010-02-11 03:20:23 UTC
Build: NetBeans IDE 6.8 (Build 200912041610)
VM: Java HotSpot(TM) Client VM, 14.0-b16, Java(TM) SE Runtime Environment, 1.6.0_14-b08
OS: Windows XP

User Comments:
GUEST: Just starting the IDE.
There is only a project open "recIntegra".



Maximum slowness yet reported was 26093 ms, average is 26093
Comment 1 Exceptions Reporter 2010-02-11 03:20:29 UTC
Created attachment 94068 [details]
nps snapshot
Comment 2 Vitezslav Stejskal 2010-02-16 09:05:29 UTC
GotoOppositeAction
Comment 3 Jaroslav Tulach 2010-02-18 02:15:45 UTC
org.netbeans.modules.gototest.GotoOppositeAction.getApplicableFileObject()
shall use NbDocument.findActivePane.

Btw. gototest module is improperly categorized as platform/actions. Please make sure you fix this in bugzilla and .nbbugzilla-components file.
Comment 4 Erno Mononen 2010-02-18 03:12:43 UTC
Not sure what this has to do with ruby/testing - I can't find anything ruby related in the snapshot, it seems that the user doesn't even have any of the ruby module activated.
Comment 5 Jaroslav Tulach 2010-02-18 05:18:32 UTC
Who's code is gototest module then? I lived under impression that it was first created for ruby and then somehow generalized. Also recent changes in the action class are from you, Erno.
Comment 6 Erno Mononen 2010-02-18 06:11:36 UTC
I've fixed one issue in the action, but I don't own the module. Passing to utils/test runner.
Comment 7 David Strupl 2010-02-22 01:47:19 UTC
As the dependent issue is marked as P2 making this one P2 as well.
Comment 8 Quality Engineering 2010-02-26 11:18:48 UTC
Integrated into 'main-golden', will be available in build *201002261426* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/8d9f9559cb00
User: Alexei Mokeev <av-nb@netbeans.org>
Log: #180595 Eliminated getEditorPane in favor of NbDocument.findRecentEditorPane
Comment 9 Alexei Mokeev 2010-02-26 23:19:03 UTC
Fixed by http://hg.netbeans.org/main/rev/8d9f9559cb00
Comment 10 Alexei Mokeev 2010-03-22 16:10:44 UTC
*** Bug 182078 has been marked as a duplicate of this bug. ***
Comment 11 Jaroslav Tulach 2010-04-16 14:39:29 UTC
*** Bug 183853 has been marked as a duplicate of this bug. ***
Comment 12 David Strupl 2010-04-28 08:23:51 UTC
*** Bug 181320 has been marked as a duplicate of this bug. ***
Comment 13 Alexei Mokeev 2010-04-28 14:49:49 UTC
*** Bug 179046 has been marked as a duplicate of this bug. ***
Comment 14 Alexei Mokeev 2010-05-05 10:39:20 UTC
*** Bug 171097 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo