Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 197679 - IDE does not automatically restart after importing settings
IDE does not automatically restart after importing settings
Status: RESOLVED WORKSFORME
Product: ide
Classification: Unclassified
Component: Import Settings
7.0
PC Windows 7
: P3 (vote)
: TBD
Assigned To: Yulia Novozhilova
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-12 22:06 UTC by maghiel
Modified: 2011-06-23 15:40 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
messages.log (65.12 KB, text/plain)
2011-04-13 19:57 UTC, maghiel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description maghiel 2011-04-12 22:06:57 UTC
[ BUILD # : 201104080000 ]
[ JDK VERSION : 1.6.23 ]

The IDE prompts for a restart when importing settings, and when choosing to do
so the IDE closes, but does not automatically restart. 
I'm having this issue for a while already, but keep forgetting to submit it
because after manually starting the IDE everything is imported fine.

Product Version: NetBeans IDE 7.0 (Build 201104080000)
Java: 1.6.0_23; Java HotSpot(TM) Client VM 19.0-b09
System: Windows 7 version 6.1 running on x86; Cp1252; nl_NL (nb)
Userdir: C:\Users\maghiel\.netbeans\7.0
Comment 1 Marian Mirilovic 2011-04-13 16:37:42 UTC
Could you please attach your messages.log file and reopen this issue ? Thanks in advance.
http://wiki.netbeans.org/FaqLogMessagesFile
Comment 2 maghiel 2011-04-13 19:57:14 UTC
Created attachment 107734 [details]
messages.log
Comment 3 Yulia Novozhilova 2011-04-28 12:27:46 UTC
Log doesn't contain any info that would help. Do you still experience this problem? If so, please start NetBeans with -J-Dorg.netbeans.modules.options.export.OptionsExportModel.level=FINEST and attach the log file here and reopen the issue. Thanks in advance.
Comment 4 maghiel 2011-06-03 21:07:45 UTC
Verified fixed in: 
Product Version: NetBeans IDE 7.0.1 Dev (Build 201106020000)
Java: 1.7.0-ea; Java HotSpot(TM) 64-Bit Server VM 21.0-b14
System: Windows 7 version 6.1 running on amd64; Cp1252; en_US (nb)
Userdir: C:\Users\maghiel\.netbeans\7.0.1dev
Comment 5 maghiel 2011-06-19 19:14:07 UTC
Reopening; experiencing same problem again in:

Product Version: NetBeans IDE Dev (Build 201106190600)
Java: 1.6.0_23; Java HotSpot(TM) Client VM 19.0-b09
System: Windows 7 version 6.1 running on x86; Cp1252; nl_NL (nb)
Userdir: C:\Users\maghiel\.netbeans\dev

I'll reproduce the issue and attach the more detailed log later tonight.
Comment 6 maghiel 2011-06-19 19:34:30 UTC
I've reinstalled using JDK 1.7.0, and now the IDE does restart. 
So the issue is probably JDK related? What to do with this report? 

Product Version: NetBeans IDE Dev (Build 201106190600)
Java: 1.7.0-ea; Java HotSpot(TM) 64-Bit Server VM 21.0-b14
System: Windows 7 version 6.1 running on amd64; Cp1252; en_US (nb)
Userdir: C:\Users\maghiel\.netbeans\dev
Comment 7 Yulia Novozhilova 2011-06-21 12:45:24 UTC
I can't reproduce the issue using jdk1.6.0_23 so closing as worsforme if you don't mind. Please feel free to reopen in case if you are able to reproduce and attach requested info. Thanks in advance.
Comment 8 maghiel 2011-06-21 15:59:11 UTC
I was able to reproduce with jdk1.6.0_23 but not with jdk7 when I posted the comments above.
So should I try to reproduce again with jdk1.6.0_23?
Comment 9 Yulia Novozhilova 2011-06-23 15:40:52 UTC
Please, try to run reinstalled Netbeans using jdk 1.6.0_23 (http://wiki.netbeans.org/FaqJdkHome) with the following option: -J-Dorg.netbeans.modules.options.export.OptionsExportModel.level=FINEST. 
If you are able reproduce the problem, attach a log here.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo