Bug 197587 - The "Availble" and "Installed" tab were empty when I opened the Plugin Manager.
The "Availble" and "Installed" tab were empty when I opened the Plugin Manager.
Status: RESOLVED DUPLICATE of bug 194407
Product: platform
Classification: Unclassified
Component: Plugin Manager
7.0
PC Other
: P2 (vote)
: TBD
Assigned To: Jaroslav Tulach
au-issues
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-09 07:50 UTC by hantsy
Modified: 2011-04-12 13:25 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
available is empty, press "Reload CataLog" can load the moudles (58.76 KB, image/png)
2011-04-09 08:14 UTC, hantsy
Details
installed is empty, there is no way to reload and view the installed modules (53.47 KB, image/png)
2011-04-09 08:15 UTC, hantsy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description hantsy 2011-04-09 07:50:41 UTC
I have just downloaded the NetBeans 7.0 rc2, and opened Plugin manager to add some other moudles.

1.Click the "Available" tab, it is empty, and I waited for a while, it is still no response, but it is strange that the right panel displays the "Embeded Browser" details.
2. Press "Reload Catalog" button, it loads all moudles from remote server.
3. When I swtich "Installed" tab, it is still empty, but the wrost is there is no "Reload" button to reload the installed modules.

What is happened in this version? Before(6.8, 6.9) it works correctly.

PS: my system: windows 7 32 bit
Java:java version "1.6.0_24"
Java(TM) SE Runtime Environment (build 1.6.0_24-b07)
Java HotSpot(TM) Client VM (build 19.1-b02, mixed mode, sharing)
I used the zip version of NetBeans.

I remembered I have posted this problem in the dev maillist, but I have not got any feedback there. I hope it will be fixed in 7.0 final release.
Comment 1 hantsy 2011-04-09 07:53:18 UTC
netbeans-7.0rc2-201104070802-ml-javaee.zip

I used this version.
Comment 2 hantsy 2011-04-09 08:14:31 UTC
Created attachment 107621 [details]
available is empty, press "Reload CataLog" can load the moudles
Comment 3 hantsy 2011-04-09 08:15:50 UTC
Created attachment 107622 [details]
installed is empty, there is no way to reload and view the installed modules
Comment 4 Marian Mirilovic 2011-04-12 07:40:03 UTC
we are having problem with JDK 7, similar to one described by you - see issue 194407 ... but as you mentioned : you are able to reproduce it on JDK 6 (is this really correct?) .. also have you tried to re-size the dialog (it might help to show the list)
Comment 5 hantsy 2011-04-12 08:50:28 UTC
yes...it is problematic with JDK 7.
NetBeans set JDK 7 as default JDK when it starts up(even I set JAVA_HOME to JDK6 installed directory and added the JDK6/bin to system path ).
I changed it in the netbeans.conf and specified the netbeans_jdkhome to D:/jdk6, it works well.
Comment 6 Marian Mirilovic 2011-04-12 08:55:05 UTC
(In reply to comment #5)
> yes...it is problematic with JDK 7.
> NetBeans set JDK 7 as default JDK when it starts up(even I set JAVA_HOME to
> JDK6 installed directory and added the JDK6/bin to system path ).
> I changed it in the netbeans.conf and specified the netbeans_jdkhome to
> D:/jdk6, it works well.

Now I am a little bit confused, so to make it clear : 
- it doesn't work on JDK 7
- it does work on JDK 6
Could you confirm this ? Thanks in advance.
Comment 7 Jesse Glick 2011-04-12 11:20:41 UTC
Sounds like a clear duplicate of bug #194407.
Comment 8 hantsy 2011-04-12 13:08:14 UTC
yes. 
JDK7 does not work.
JDK6 OK.
Comment 9 Jesse Glick 2011-04-12 13:25:44 UTC

*** This bug has been marked as a duplicate of bug 194407 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo