Bug 194407 - 70cat [Plugins dialog] Installed Plugin Tab does not show list of plugins installed
70cat [Plugins dialog] Installed Plugin Tab does not show list of plugins ins...
Status: CLOSED WONTFIX
Product: platform
Classification: Unclassified
Component: Plugin Manager
7.0
All All
: P2 (vote)
: 7.0
Assigned To: Jaroslav Tulach
au-issues
fix-in-nb701 jdk_bug_11869191 jdk_bug...
: JDK_1.7, VISUALVM
: 190485 192668 193023 195265 197242 197587 198240 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-17 04:27 UTC by manikantannaren
Modified: 2011-06-09 07:21 UTC (History)
9 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
No plugins shown. (31.95 KB, image/png)
2011-01-17 04:29 UTC, manikantannaren
Details
Plugins shown after clicking "Show details" checkbox (48.88 KB, image/png)
2011-01-17 04:32 UTC, manikantannaren
Details

Note You need to log in before you can comment on or make changes to this bug.
Description manikantannaren 2011-01-17 04:27:50 UTC
[ BUILD # : 201101160000 ]
[ JDK VERSION : 1.7 ]

1. Installed the latest nightly build (201101160000). 
2. Brought up the Plugins dialog. 
3. Clicked on the installed plugins tab. The tab label shows "Installed (5)"
4. But the list is empty

To show the list
1. Click on Show details check box (will show you all the plugins but
ungrouped)
2. Click again on the Show details check box - should show the summary view.
Comment 1 manikantannaren 2011-01-17 04:29:30 UTC
Created attachment 105056 [details]
No plugins shown.
Comment 2 manikantannaren 2011-01-17 04:32:30 UTC
Created attachment 105057 [details]
Plugins shown after clicking "Show details" checkbox
Comment 3 Jaroslav Tulach 2011-02-18 19:20:45 UTC
ergonomics#0655e5e8c5e2: more logging and checking assert earlier.
Comment 4 manikantannaren 2011-02-21 04:33:36 UTC
Works with Java 6 but not Java 7 build 1.7.0-ea-b119
Comment 5 Marian Mirilovic 2011-02-23 17:49:38 UTC
*** Bug 192668 has been marked as a duplicate of this bug. ***
Comment 6 Marian Mirilovic 2011-02-23 17:50:44 UTC
*** Bug 193023 has been marked as a duplicate of this bug. ***
Comment 7 Marian Mirilovic 2011-02-23 17:51:01 UTC
*** Bug 190485 has been marked as a duplicate of this bug. ***
Comment 8 Marian Mirilovic 2011-02-23 17:56:41 UTC
Jarda, 
we need to track this issue as fixed or wontfix (if it's an JDK issue already reported and you have a number in the hand).

BTW: I am able to reproduce it for 100% in :
Product Version: NetBeans IDE Dev (Build 201102230001)
Java: 1.7.0-ea; Java HotSpot(TM) 64-Bit Server VM 21.0-b02
System: Linux version 2.6.35-25-generic running on amd64; UTF-8; en_US (nb)
Comment 9 Marian Mirilovic 2011-02-23 18:01:28 UTC
*** Bug 195265 has been marked as a duplicate of this bug. ***
Comment 10 Jaromir Uhrik 2011-02-25 08:55:32 UTC
Reproducible also on Ubuntu 10.10 so the Platform field is now correctly ALL.

Details of config where I am able to reproduce:
Product Version: NetBeans IDE Dev (Build 201102250001)
Java: 1.7.0-ea; Java HotSpot(TM) Client VM 21.0-b02
System: Linux version 2.6.35-22-generic running on i386; UTF-8; en_US (nb)
Comment 11 Jaroslav Tulach 2011-02-26 19:20:49 UTC
You'll have to show it to me on Monday guys.
Comment 12 Jaroslav Tulach 2011-02-28 16:05:25 UTC
OK. According to Standa, this is a bug in JDK. The fact that the content of the JTable is correct and just needs a repaint request (after resizing), seems to indicate the problem is in rendering.

The fact that this used to work in 1.6 also indicates the is a regression. 

What is the proper step right now? Close as won'tfix?
Comment 13 Marian Mirilovic 2011-02-28 18:34:41 UTC
(In reply to comment #12)
> What is the proper step right now? Close as won'tfix?

We need to have JDK bug ID (and escalate - mngrs' job). Yarda/Standa, do you have ID of JDK bug ?
Comment 14 Petr Jiricka 2011-03-10 16:32:42 UTC
Reopening until we have a JDK bug number.
Comment 15 Marian Mirilovic 2011-04-01 07:58:49 UTC
*** Bug 197242 has been marked as a duplicate of this bug. ***
Comment 16 Jesse Glick 2011-04-12 13:25:44 UTC
*** Bug 197587 has been marked as a duplicate of this bug. ***
Comment 17 Marian Mirilovic 2011-05-02 13:15:27 UTC
*** Bug 198240 has been marked as a duplicate of this bug. ***
Comment 18 asenk 2011-06-08 09:20:16 UTC
Verified on

Product Version: NetBeans IDE 7.0.1 Dev (Build 201106072116)
Java: 1.7.0-ea; Java HotSpot(TM) Client VM 21.0-b15
System: Linux version 2.6.32-32-generic running on i386; UTF-8; en_US (nb)
Comment 19 Marian Mirilovic 2011-06-09 07:21:30 UTC
Fixed in build 143 of JDK 7


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo