Bug 197061 - Code folding is missing in html, php...
Code folding is missing in html, php...
Status: RESOLVED DUPLICATE of bug 198006
Product: web
Classification: Unclassified
Component: HTML Editor
7.0.1
PC Windows 7
: P2 (vote)
: 7.0.1
Assigned To: Marek Fukala
issues@javaee
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-24 19:13 UTC by Vladimir Riha
Modified: 2011-05-03 11:38 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
screenshot (28.80 KB, image/png)
2011-03-24 19:13 UTC, Vladimir Riha
Details
better screenshot (24.67 KB, image/png)
2011-03-24 19:17 UTC, Vladimir Riha
Details
Another screenshot (109.16 KB, image/png)
2011-03-28 07:18 UTC, Vladimir Riha
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Riha 2011-03-24 19:13:22 UTC
Created attachment 107258 [details]
screenshot

There is absolutely no code folding for html, xhtml (jsf), and php web page files. Reopening the file doesn't help. Folding works in JSP files.


Product Version: NetBeans IDE Dev (Build 201103240400)
Java: 1.6.0_24; Java HotSpot(TM) Client VM 19.1-b02
System: Windows 7 version 6.1 running on x86; Cp1250; cs_CZ (nb)
Comment 1 Vladimir Riha 2011-03-24 19:17:02 UTC
Created attachment 107259 [details]
better screenshot
Comment 2 Marek Fukala 2011-03-25 21:34:05 UTC
Works fine for me in the last dev build. BTW, do you mean there's no HTML code folding or no folding at all (so no php folds in the php files)?

If the parsing.api doesn't finish the parsing it the folds will likely never show up. In such case the "Please wait..." text in the navigator bar area never disappears. Isn't it that case? Does this hapeen for brand new userdir and new project or just in some specific context?

I'm closing as worksforme for now, please possibly reopen along with adding the requested info. Thanks.
Comment 3 Vladimir Riha 2011-03-28 07:18:15 UTC
Created attachment 107323 [details]
Another screenshot

There are no folds at all, look at the screenshot (it shows php file and xhtml file from JSF project, the same happens with simple html5 file). The parsing seems to be finished, navigation bar shows path (tags) as it should. I tested in new user dir, with PHP and JavaWeb JSF project (but JSP file works fine even in the same project)

Product Version: NetBeans IDE Dev (Build 201103280400)
Java: 1.6.0_24; Java HotSpot(TM) Client VM 19.1-b02
System: Windows XP version 5.1 running on x86; Cp1250; cs_CZ (nb)
Comment 4 Marek Fukala 2011-03-28 13:12:09 UTC
now I can reproduce...
Comment 5 Marek Fukala 2011-03-28 13:39:38 UTC
Is the folding ok in the 7.0 rc builds?
Comment 6 Vladimir Riha 2011-03-28 15:46:26 UTC
Yes, this problem is only in dev build, rc is fine.
Comment 7 Petr Jiricka 2011-03-29 22:35:16 UTC
So if this is trunk-only, fix-in-nb701 whiteboard should be removed. Also it should be excluded from the bug dashboard: either we should add the NO70 keyword, or dashboard should automatically exclude all bugs with Version == Dev.
Comment 8 Marek Fukala 2011-05-03 07:37:29 UTC

*** This bug has been marked as a duplicate of bug 198006 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo