Bug 196909 - java.net.URISyntaxException: Illegal character in opaque part at index 7: file:D:\nat\trunk\nat\robot\implementation/src/repository/
java.net.URISyntaxException: Illegal character in opaque part at index 7: fil...
Status: RESOLVED FIXED
Product: projects
Classification: Unclassified
Component: Maven
7.0
All All
: P3 (vote)
: 7.0.1
Assigned To: Jesse Glick
issues@projects
EXCEPTIONS_REPORT
:
: 198157 199433 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-21 09:09 UTC by Exceptions Reporter
Modified: 2011-06-22 20:28 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (2.11 KB, text/plain)
2011-03-21 09:09 UTC, Exceptions Reporter
Details
the offending pom.xml (9.54 KB, text/xml)
2011-03-21 16:29 UTC, jgzornoza
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2011-03-21 09:09:40 UTC
Build: NetBeans IDE 7.0 Beta 2 (Build 201102140001)
VM: Java HotSpot(TM) Client VM, 19.1-b02, Java(TM) SE Runtime Environment, 1.6.0_24-b07
OS: Windows XP

User Comments:
jgzornoza: renaming package on a mavenized swing project

GUEST: Started up IDE
In Help menu checked for updates, confirmed message "is up to date"
switched to other window (browser) and later back again
to see popup with exception message




Stacktrace: 
java.net.URISyntaxException: Illegal character in opaque part at index 7: file:D:\nat\trunk\nat\robot\implementation/src/repository/
   at java.net.URI$Parser.fail(URI.java:2809)
   at java.net.URI$Parser.checkChars(URI.java:2982)
   at java.net.URI$Parser.parse(URI.java:3019)
   at java.net.URI.<init>(URI.java:578)
   at java.net.URI.create(URI.java:840)
   at org.netbeans.modules.maven.indexer.NexusRepositoryIndexerImpl.indexLoadedRepo(NexusRepositoryIndexerImpl.java:501)
Comment 1 Exceptions Reporter 2011-03-21 09:09:44 UTC
Created attachment 107147 [details]
stacktrace
Comment 2 Jesse Glick 2011-03-21 15:00:20 UTC
Looks like a user error. Perhaps the POM has

<repository>...<url>file:${basedir}/src/repository/</></>

which is not a valid URL on Windows (though it would happen to work on Unix).
Comment 3 Jesse Glick 2011-03-21 15:08:05 UTC
core-main #cf4061a31013
Comment 4 jgzornoza 2011-03-21 16:29:28 UTC
Created attachment 107157 [details]
the offending pom.xml

The error message window appears when I try to make a text search on the attached pom.xml
Comment 5 jgzornoza 2011-03-21 16:29:40 UTC
The error message window appears when I try to make a text search on the attached pom.xml
Comment 6 Jesse Glick 2011-03-21 16:32:51 UTC
(In reply to comment #4)
> The error message window appears when I try to make a text search on the
> attached pom.xml

I think it's caused by some other POM, with an illegal local <repository>.
Comment 7 Quality Engineering 2011-03-22 09:57:27 UTC
Integrated into 'main-golden', will be available in build *201103220400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/cf4061a31013
User: Jesse Glick <jglick@netbeans.org>
Log: #196909: java.net.URISyntaxException: Illegal character in opaque part at index 7: file:D:\nat\trunk\nat\robot\implementation/src/repository/
Comment 8 Jesse Glick 2011-05-02 13:09:01 UTC
*** Bug 198157 has been marked as a duplicate of this bug. ***
Comment 9 Jesse Glick 2011-06-22 20:28:48 UTC
*** Bug 199433 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo