Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 19527 - Property Marking vanish after invoking Property Editor
Property Marking vanish after invoking Property Editor
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Explorer
3.x
Sun Solaris
: P3 (vote)
: 3.x
Assigned To: _ tboudreau
issues@platform
:
: 18553 (view as bug list)
Depends on: 29447 31896
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-17 13:06 UTC by Marian Mirilovic
Modified: 2008-12-22 20:36 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marian Mirilovic 2002-01-17 13:06:02 UTC
[nb331_dev](20020117), [jdk1.3.1](02) & [jdk1.4](91)

Steps to reproduce:
- open/create JInternalFrame
- property "frameIcon" has PropertyMarking
- invoke Property Editor , push "..."
-> Property Marking vanished
Comment 1 David Strupl 2002-01-17 13:10:54 UTC
*** Issue 18553 has been marked as a duplicate of this issue. ***
Comment 2 Rochelle Raccah 2002-02-07 03:40:30 UTC
Another case:

If my property value is illegally marked and I open my editor then
cancel, the marking doesn't reappear until I switch to another node
and back or mouse back and forth over the properties in this sheet. 
It should automatically refresh when the editor is closed.
Comment 3 Jiri Rechtacek 2002-02-28 16:07:46 UTC
There is a problem the PropertyEnv is set to STATE_NEEDS_VALIDATION in
the IconPanel constructor (as hotfix issue 19520). So the initialize
value in property dialog is STATE_NEEDS_VALIDATION then if the dialog
is canceled the propertyEnv is set on STATE_NEEDS_VALIDATION back. It
should be investigated more...
Comment 4 Marek Grummich 2002-07-22 11:25:57 UTC
Set target milestone to TBD
Comment 5 Marek Grummich 2002-07-22 11:28:03 UTC
Set target milestone to TBD
Comment 6 Jiri Rechtacek 2002-11-08 07:52:09 UTC
Davide, could you look on this? The 'modified' icon should solve same
problem as 'invalid' icon.
Comment 7 David Strupl 2003-01-06 15:29:45 UTC
Sorry Tim - my code but your subcomponent now. I hope that this might
be solved by (after) your JTable rewrite but one never knows.
Comment 8 _ tboudreau 2003-04-09 17:39:57 UTC
Adding to ps rewrite umbrella.  FWIW I just tested it with
the branch code, and it is indeed fixed.
Comment 9 _ tboudreau 2003-10-24 10:17:44 UTC
Question - has something changed with frameIcon - does it still get 
marking?  I can't reproduce property marking on it at all in the 
current trunk, but my unit tests for property marking show it to be 
working perfectly in the property panel rewrite branch.  
Comment 10 Rochelle Raccah 2003-10-28 22:59:40 UTC
The case I mentioned appears to work in the last qbuild.  However, 
marking doesn't show up at all in some cases.  The best I can tell is 
those are combo boxes.  Should I file a separate issue?
Comment 11 _ tboudreau 2003-10-30 08:17:55 UTC
Don't bother, it's already fixed for combo boxes on the property panel
rewrite branch, with a unit test to make sure it doesn't break in the
future.
Comment 12 _ tboudreau 2003-12-09 09:36:57 UTC
Property panel rewrite branch merged.
Comment 13 Lukas Hasik 2003-12-10 15:57:19 UTC
200312091900


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo