Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 18553 - Illegal value shows error icon before ok
Illegal value shows error icon before ok
Status: CLOSED DUPLICATE of bug 19527
Product: platform
Classification: Unclassified
Component: -- Other --
3.x
All All
: P3 (vote)
: 3.x
Assigned To: David Strupl
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-12 02:13 UTC by Rochelle Raccah
Modified: 2008-12-22 21:50 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rochelle Raccah 2001-12-12 02:13:24 UTC
- Set up a Data Object property editor to accept a top level data object like a
Java file.
- Make sure the property sheet is visible in the background while the editor is
open.
- Selecting something which disables ok (like a folder).
- The illegal icon is shown in the property sheet.

There should be no update to the property sheet until the user chooses a new
value and hits ok.
Comment 1 David Strupl 2002-01-07 15:17:28 UTC
Will require a small change in PropertyPanel. Testing the fix, hope to
commit soon. This is not an issue in DataObjectEditor - it applies to
all editors.
Comment 2 David Strupl 2002-01-07 15:57:04 UTC
Fixed in PropertyPanel 1.89.2.2 (on release33 branch).
Comment 3 Rochelle Raccah 2002-01-11 05:43:59 UTC
David told me that his fix for issue 18552 caused a regression here
which he fixed in the following way:

If a value is legal and then an illegal value is shown in the popup
editor, there is no error icon.  If the value in the sheet is illegal
and the editor is opened, the error icon is hidden.  We discussed this
and decided it was not optimal behavior, but it was better than the
old behavior.

A suggestion was made by me to "clone" the environment from the
property sheet to the opened property editor so one can have an
illegal value while the other has a valid value.  Once the user hits
okay, the selection in the popup editor is applied.  If the user hits
cancel, it is discarded.  This issue is being reopened to track this
suggestion.
Comment 4 Jan Chalupa 2002-01-11 14:05:15 UTC
Target milestone -> 3.4
Comment 5 Jan Chalupa 2002-01-11 14:08:49 UTC
Target milestone -> 3.4
Comment 6 Jan Chalupa 2002-01-11 14:09:35 UTC
Target milestone -> 3.4
Comment 7 Jan Chalupa 2002-01-11 14:12:09 UTC
Target milestone -> 3.4
Comment 8 David Strupl 2002-01-17 13:10:54 UTC
The same issue was entered again (by someone else). I am marking this
as duplicate of the other one.

*** This issue has been marked as a duplicate of 19527 ***
Comment 9 Rochelle Raccah 2002-01-17 15:43:28 UTC
Yes, the other issue describes the same symptom, but this issue was
meant to become a more generic solution (cloning the env doesn't just
affect the marking).  If you still feel they are duplicates, that's
fine.  Otherwise, reopen this one and change the summary, please.
Comment 10 Quality Engineering 2003-07-01 15:57:40 UTC
Resolved for 3.4.x or earlier, no new info since then -> verified.

Comment 11 Quality Engineering 2003-07-01 16:16:05 UTC
Resolved for 3.4.x or earlier, no new info since then -> closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo