Bug 192190 - Ant cannot be run when NB path contains space and Latin-1 char
Ant cannot be run when NB path contains space and Latin-1 char
Status: VERIFIED FIXED
Product: projects
Classification: Unclassified
Component: Ant
7.0
All All
: P2 (vote)
: 7.0
Assigned To: Jesse Glick
issues@projects
https://issues.apache.org/bugzilla/sh...
: SPACE_IN_PATH
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-19 18:42 UTC by luisakamotor
Modified: 2011-01-12 04:08 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
screen error (163.09 KB, image/png)
2010-11-25 17:33 UTC, luisakamotor
Details
printscreen_02 (319.63 KB, image/x-png)
2010-11-26 02:56 UTC, luisakamotor
Details
printscreen_03 (398.57 KB, image/x-png)
2010-11-26 02:56 UTC, luisakamotor
Details
Screen Error on 03/01/2011 (271.61 KB, image/png)
2011-01-03 14:10 UTC, luisakamotor
Details
debug_01 (16.61 KB, text/plain)
2011-01-04 01:46 UTC, luisakamotor
Details
debug_02 (159.87 KB, text/plain)
2011-01-04 01:47 UTC, luisakamotor
Details
debug_03 (160.42 KB, text/plain)
2011-01-04 01:47 UTC, luisakamotor
Details
Patch (3.03 KB, patch)
2011-01-05 09:27 UTC, Tomas Zezula
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description luisakamotor 2010-11-19 18:42:50 UTC
After recent updates, it's impossible to build projects in java.

I have this exception:
	java.io.FileNotFoundException: C:\Users\Lu�s Pedro\.netbeans\6.9\ant\nblib\org-netbeans-modules-mobility-project.jar (The system cannot find the path specified)

Pathname is right and jar requested is there. Which is the problem?
My user name is "Luís Pedro" and not "Lu�s Pedro"(like netbeans recognize).

Please solve this problem fast. :S

Thanks!

---------------------------------
Product Version = NetBeans IDE 6.9.1 (Build 201011082200)
Operating System = Windows 7 version 6.1 running on x86
Java; VM; Vendor = 1.6.0_22
Runtime = Java HotSpot(TM) Client VM 17.1-b03
---------------------------------
Comment 1 Marian Mirilovic 2010-11-23 08:42:00 UTC
You said 'after recent update' - does it mean it worked before ?
Comment 2 Jaroslav Tulach 2010-11-23 11:12:23 UTC
Do you have full stacktrace of the exception you are facing? Without it, I cannot really tell where the problem is.

However the problem with wrong character may be related to bug 189988.
Comment 3 luisakamotor 2010-11-25 17:33:25 UTC
Created attachment 103337 [details]
screen error
Comment 4 luisakamotor 2010-11-25 17:51:37 UTC
Like I said before:

 - file reported as missing.... is there:
    C:\Users\Luís Pedro\.netbeans\6.9\ant\nblib\org-netbeans-modules-mobility-project.jar

 - netbeans report file location in:
    C:\Users\Lu�s Pedro\.netbeans\6.9\ant\nblib\org-netbeans-modules-mobility-project.jar
   (you can see that in new attachment)

I don't think that is related with bug 189988.

This only happened with my computers where my windows user name account is "Luís Pedro" and only with this file. I think that is related with letter "í". http://en.wikipedia.org/wiki/Acute_accent

In my other pcs with windows user name "LPC", i can use files or folders with accents in their name with no problem.

This error only happened after update in 6.9.1.

Please, I guess that this is any encoding problem recognition from last updates.

I can't work in these PCs.

Some of my friends are experiencing same problems with windows user names like João" or "António".

You need more data to identify the problem?


Sorry for my bad english!

Thanks!
Comment 5 Jaroslav Tulach 2010-11-25 18:50:26 UTC
If there is something wrong in the IDE, then it would be bug 189988. If you cannot build a project, that is a different story. Either Ant specific or Java specific.
Comment 6 Tomas Zezula 2010-11-25 21:30:44 UTC
Please can you try the NB 7.0 dev build to see if it's not the problem Jarda has fixed.
The build can be downloaded http://bits.netbeans.org/download/trunk/nightly/latest/.
If you have still the problem with the dev build can you attach the ant debug output?
You can do it by setting Tools/Options/Miscellaneous/Ant/Verbosity Level to debug before the build.
It will be also good if you can attach the project metadata (nbproject folder).
Which encoding is the OS using?
Thanks very much
Comment 7 luisakamotor 2010-11-26 02:52:34 UTC
Sorry, moments before I read this mail... I tried with build "netbeans-trunk-nightly-201011250001-ml-windows". I have the results from two computers
It works! :)

I always used the latest dev version since 5.5. After 6.9.1/7.0 M2 November 11th updates, this error shows up.

Latest nightly version, don´t have same error anymore.

Now i'm trying with Netbeans 6.9.1 with latest updates(instaled right now in this laptop)....

Don't work in 6.9.1. Same error! (printscreen_02)

My other PC, with same build(6.9.1) have the same problem. Dev version it's okay. (printscreen_03)

Conclusion: Problem solved in latest nightly version. Error still applies to 6.9.1 / 7.0 Beta version.

Thanks!
Comment 8 luisakamotor 2010-11-26 02:56:09 UTC
Created attachment 103345 [details]
printscreen_02
Comment 9 luisakamotor 2010-11-26 02:56:42 UTC
Created attachment 103346 [details]
printscreen_03
Comment 10 Tomas Zezula 2010-11-26 07:52:49 UTC
Seems fixed by Jarda as he described above in NB 7.0.
If you have some encoding issues in NB 7.0 please reopen this issue or create a new one.  It's very hard to detect such problems without localized OS.
Thanks very much for your help.
Comment 11 Marian Mirilovic 2010-12-03 08:27:21 UTC
Removed '69patch-candidate' ... this was de-facto fixed by fix of issue 189988, so that fix will be a part of the patch.
Comment 12 luisakamotor 2011-01-03 14:07:57 UTC
Hi!

Again... :S After recent updates, it's impossible to build projects in java in same conditions of previous bug.

I have this exception:
       java.io.FileNotFoundException: C:\Users\Lu�s Pedro\.netbeans\dev\ant\nblib\org-netbeans-modules-java-source-ant.jar (The system cannot find the path specified)

Thanks!
Comment 13 luisakamotor 2011-01-03 14:10:35 UTC
Created attachment 104664 [details]
Screen Error on 03/01/2011
Comment 14 luisakamotor 2011-01-03 14:11:59 UTC
Sorry, I forget adding the System Info...

Product Version: NetBeans IDE Dev (Build nbms-and-javadoc-6313-on-101212)
Java: 1.7.0-ea; Java HotSpot(TM) 64-Bit Server VM 20.0-b03
System: Windows 7 version 6.1 running on amd64; Cp1252; en_US (nb)
Userdir: C:\Users\Luís Pedro\.netbeans\dev
Comment 15 Tomas Zezula 2011-01-03 15:48:28 UTC
Please can you attach the output of ant verbose output?
It would be good if you can do it both from IDE and command line.

For the IDE:
In the Tools/Options select Miscellaneous/Ant and change the Verbosity Level from Normal to Debug.
Then do the build. In the output window lots of details is printed. Please attach it.

For the cmd line:
In the project folder type ant -debug jar > debug.txt and attach ten debug.txt


One more thing, can you try to turn off the Compile On save and try it again. You can turn off the compile on save in the Project's properties (Compiling/Compile On Save).
If you have any question feel free to ask and thanks again for help.
Comment 16 luisakamotor 2011-01-04 01:45:53 UTC
Thanks...

1st - Compile On Save - Disabled -> Same error.

2nd - Ant - Verbosity Level - Debug -> Attachment - debug_01.txt

3rd - In CMD - with ANT 1.8.1(ant folder copy/pasted from actual version of Netbeans) -> Attachment - debug_02.txt

4th - In CMD - with ANT 1.8.2(that i have installed on my machine) -> Attachment - debug_03.txt

Seems that ANT works fine with original(Netbeans) and latest version, but not Netbeans using original ANT. :S

If I do something wrong tell me please.
Comment 17 luisakamotor 2011-01-04 01:46:48 UTC
Created attachment 104678 [details]
debug_01
Comment 18 luisakamotor 2011-01-04 01:47:08 UTC
Created attachment 104679 [details]
debug_02
Comment 19 luisakamotor 2011-01-04 01:47:27 UTC
Created attachment 104680 [details]
debug_03
Comment 20 Tomas Zezula 2011-01-04 17:11:22 UTC
Thanks for the data.
It seems as a bug in the org.apache.tools.ant.launch.Locator.decodeUri(String).
The problem is in the org.apache.tools.ant.launch.Locator.decodeUri(String) which takes chars and adds
them into ByteArrayOutputStream (line 316) causing the upper bits to be thrown away. The method uses the ByteArrayOutputStream because of the decoding of % escape but for non escaped chars > 127 it doesn't work.
Comment 21 Tomas Zezula 2011-01-05 09:27:02 UTC
Created attachment 104717 [details]
Patch
Comment 22 Tomas Zezula 2011-01-05 09:30:36 UTC
Reassigning to projects/ant to review.
Comment 23 Jesse Glick 2011-01-05 14:19:25 UTC
Reproducible with NB in "/tmp/açaí berry" on Ubuntu. My initial attempts to reproduce failed because (1) there must be a space character or some other ASCII metachar to produce a %-escape, (2) characters above 255 (e.g. č) do not cause a problem, only U+0080 through U+00FF (I think).
Comment 24 Tomas Zezula 2011-01-05 14:24:47 UTC
Yes, the space is required otherwise the Locator.decodeUri does not do anything.
Those characters which have higher byte of char set are truncated in the ByteArrayOutputStream.write.
Comment 25 Jesse Glick 2011-01-05 14:49:07 UTC
core-main #987a9649ce3c
Comment 26 luisakamotor 2011-01-06 02:35:51 UTC
This night, with Ant Update, problem seems resolved.

Thanks!!! :)

PS: I hate Eclipse... back to Netbeans!!! :)
Comment 27 Quality Engineering 2011-01-06 09:15:39 UTC
Integrated into 'main-golden', will be available in build *201101060001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/987a9649ce3c
User: Jesse Glick <jglick@netbeans.org>
Log: #192190: Ant cannot be run when NB path contains space and Latin-1 char
Comment 28 Jesse Glick 2011-01-12 04:08:30 UTC
Thanks for verification!

Apparently I neglected to link to the Ant bug that I filed (and fixed for 1.8.3).


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo