Bug 191847 - UI lock when deleting project with sources
UI lock when deleting project with sources
Status: RESOLVED FIXED
Product: projects
Classification: Unclassified
Component: Ant
6.x
PC Linux
: P2 (vote)
: 7.0
Assigned To: Jesse Glick
issues@projects
69patch-candidate
: THREAD
: 189142 200000 (view as bug list)
Depends on:
Blocks: 183103
  Show dependency treegraph
 
Reported: 2010-11-11 13:33 UTC by Jiri Kovalsky
Modified: 2011-07-12 10:05 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Screenshot of UI lock when deleting project. (149.25 KB, image/png)
2010-11-11 13:33 UTC, Jiri Kovalsky
Details
Full thread dump taken when IDE was locked with a modal dialog. (23.24 KB, text/plain)
2010-11-11 13:35 UTC, Jiri Kovalsky
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Kovalsky 2010-11-11 13:33:28 UTC
Created attachment 102906 [details]
Screenshot of UI lock when deleting project.

Product Version: NetBeans IDE 7.0 Beta (Build 201011110000)
Java: 1.6.0_22; Java HotSpot(TM) Client VM 17.1-b03
System: Linux version 2.6.31-22-generic running on i386; UTF-8; en_US (nb)
Userdir: /home/cesilko/.netbeans/7.0beta

Description:
============
IDE locks when deleting a project with sources while another project is being debugged. I am attaching full thread dump and screenshot. The confirmation dialog is modal and both buttons are disabled so the only way to go on is to kill the IDE.

Steps to reproduce:
===================
1. Launch NetBeans IDE 7.0 Beta candidate build #201011110000.
2. Generate Anagram Game sample project.
3. Toggle breakpoint at line 60 in Anagrams.java and press Ctrl+F5.
4. Once debugging session is started generate new basic shell Java desktop application.
5. Once it is created, invoke "Delete" action from popup menu of the second project.
6. Check "Also delete sources..." option and push "Yes" button.
7. The project node will disappear but the "Delete Project" dialog stays open forever.
Comment 1 Jiri Kovalsky 2010-11-11 13:35:07 UTC
Created attachment 102908 [details]
Full thread dump taken when IDE was locked with a modal dialog.

Just for the record, escaping the dialog didn't help, clicking "x" button either.
Comment 2 Jesse Glick 2010-11-11 19:13:53 UTC
Reproducible even in 6.9 and I think I know the cause.
Comment 3 Jesse Glick 2010-11-11 19:16:04 UTC
core-main #af13d26e1fd2
Comment 4 Quality Engineering 2010-11-13 06:39:02 UTC
Integrated into 'main-golden', will be available in build *201011130001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/af13d26e1fd2
User: Jesse Glick <jglick@netbeans.org>
Log: #191847: UI lock when deleting project with sources
Comment 5 Jesse Glick 2011-07-12 10:05:20 UTC
*** Bug 189142 has been marked as a duplicate of this bug. ***
Comment 6 Jesse Glick 2011-07-12 10:05:26 UTC
*** Bug 200000 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo