Bug 190339 - Netbeans 6.9.1 hangs frequently.
Netbeans 6.9.1 hangs frequently.
Status: RESOLVED DUPLICATE of bug 187615
Product: projects
Classification: Unclassified
Component: Maven
6.x
PC Linux
: P1 (vote)
: TBD
Assigned To: Jesse Glick
issues@projects
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-13 14:58 UTC by elishae
Modified: 2010-09-16 15:30 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description elishae 2010-09-13 14:58:24 UTC
I'm encountering frequent "Hang" in the Netbeans 6.9.1.

When the IDE is hung, Connecting to the process using jconsole, and invoking 'detect deadlock' in the 'threads' tab shows that more than couple of threads are in 'deadlock'.

Will update the dead lock info in subsequent comment.
Comment 1 elishae 2010-09-13 15:16:29 UTC
Name: Default RequestProcessor
State: BLOCKED on org.openide.windows.CloneableOpenSupport$Listener@19fffa0 owned by: AWT-EventQueue-1
Total blocked: 57  Total waited: 49
Stack trace: 
org.openide.text.CloneableEditorSupport.openDocument(CloneableEditorSupport.java:806)
org.openide.text.DataEditorSupport.openDocument(DataEditorSupport.java:496)
org.netbeans.modules.maven.model.Utilities._getDocument(Utilities.java:168)
org.netbeans.modules.maven.model.Utilities.access$000(Utilities.java:93)
org.netbeans.modules.maven.model.Utilities$1.getLookup(Utilities.java:226)
org.openide.util.lookup.SimpleProxyLookup.checkLookup(SimpleProxyLookup.java:80)
org.openide.util.lookup.SimpleProxyLookup.lookup(SimpleProxyLookup.java:155)
org.netbeans.modules.xml.xam.AbstractModelFactory.getEffectiveAccessProvider(AbstractModelFactory.java:119)
org.netbeans.modules.xml.xam.AbstractModelFactory.getKey(AbstractModelFactory.java:111)
org.netbeans.modules.xml.xam.AbstractModelFactory.getModel(AbstractModelFactory.java:132)
   - locked org.netbeans.modules.maven.model.pom.POMModelFactory@139e2f7
org.netbeans.modules.maven.model.pom.POMModelFactory.getModel(POMModelFactory.java:78)
org.netbeans.modules.maven.navigator.POMModelPanel.run(POMModelPanel.java:312)
org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1418)
org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:1957)
------------------------------------------------------


Name: AWT-EventQueue-1
State: BLOCKED on org.netbeans.modules.maven.model.pom.impl.POMModelImpl@726d23 owned by: StatusProvider
Total blocked: 8,487  Total waited: 8,231
Stack trace: 
org.netbeans.modules.xml.xam.dom.AbstractDocumentModel.getAccess(AbstractDocumentModel.java:571)
org.netbeans.modules.xml.xam.dom.AbstractDocumentModel.documentChanged(AbstractDocumentModel.java:147)
org.netbeans.modules.xml.xam.dom.AbstractDocumentModel.access$100(AbstractDocumentModel.java:79)
org.netbeans.modules.xml.xam.dom.AbstractDocumentModel$DocumentChangeListener.removeUpdate(AbstractDocumentModel.java:200)
org.netbeans.modules.xml.xam.dom.AbstractDocumentModel$WeakDocumentListener.removeUpdate(AbstractDocumentModel.java:173)
org.netbeans.lib.editor.util.swing.PriorityDocumentListenerList.removeUpdate(PriorityDocumentListenerList.java:102)
javax.swing.text.AbstractDocument.fireRemoveUpdate(AbstractDocument.java:243)
org.netbeans.editor.BaseDocument.fireRemoveUpdate(BaseDocument.java:1664)
org.netbeans.editor.BaseDocument.remove(BaseDocument.java:959)
org.openide.text.CloneableEditorSupport$4.run(CloneableEditorSupport.java:770)
org.netbeans.editor.GuardedDocument.runAtomic(GuardedDocument.java:314)
org.openide.text.NbDocument.runAtomic(NbDocument.java:422)
org.openide.text.CloneableEditorSupport.clearDocument(CloneableEditorSupport.java:764)
org.openide.text.CloneableEditorSupport.access$1700(CloneableEditorSupport.java:126)
org.openide.text.CloneableEditorSupport$6$1Query.call(CloneableEditorSupport.java:1695)
org.openide.text.CloneableEditorSupport$6.run(CloneableEditorSupport.java:1708)
org.netbeans.editor.GuardedDocument.runAtomic(GuardedDocument.java:314)
org.openide.text.NbDocument.runAtomic(NbDocument.java:422)
org.openide.text.CloneableEditorSupport.reloadDocument(CloneableEditorSupport.java:1658)
org.openide.text.CloneableEditorSupport.checkReload(CloneableEditorSupport.java:2292)
   - locked org.openide.windows.CloneableOpenSupport$Listener@19fffa0
org.openide.text.CloneableEditorSupport.access$2600(CloneableEditorSupport.java:126)
org.openide.text.CloneableEditorSupport$Listener$1.run(CloneableEditorSupport.java:2928)
org.netbeans.editor.GuardedDocument.runAtomic(GuardedDocument.java:314)
org.openide.text.NbDocument.runAtomic(NbDocument.java:422)
org.openide.text.CloneableEditorSupport$Listener$1.run(CloneableEditorSupport.java:2920)
java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
java.awt.EventQueue.dispatchEvent(EventQueue.java:597)
org.netbeans.core.TimableEventQueue.dispatchEvent(TimableEventQueue.java:137)
java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
java.awt.EventDispatchThread.run(EventDispatchThread.java:122)
-----------------------------------------------


Name: StatusProvider
State: BLOCKED on org.openide.windows.CloneableOpenSupport$Listener@19fffa0 owned by: AWT-EventQueue-1
Total blocked: 67  Total waited: 42
Stack trace: 
org.openide.text.CloneableEditorSupport.openDocument(CloneableEditorSupport.java:806)
org.openide.text.DataEditorSupport.openDocument(DataEditorSupport.java:496)
org.netbeans.modules.maven.model.Utilities._getDocument(Utilities.java:168)
org.netbeans.modules.maven.model.Utilities.access$000(Utilities.java:93)
org.netbeans.modules.maven.model.Utilities$1.getLookup(Utilities.java:226)
org.openide.util.lookup.SimpleProxyLookup.checkLookup(SimpleProxyLookup.java:80)
org.openide.util.lookup.SimpleProxyLookup.lookup(SimpleProxyLookup.java:155)
org.netbeans.modules.xml.xam.dom.AbstractDocumentModel.needsSync(AbstractDocumentModel.java:118)
org.netbeans.modules.xml.xam.AbstractModel.sync(AbstractModel.java:278)
   - locked org.netbeans.modules.maven.model.pom.impl.POMModelImpl@726d23
org.netbeans.modules.maven.hints.pom.StatusProvider$StatusProviderImpl.findHints(StatusProvider.java:139)
org.netbeans.modules.maven.hints.pom.StatusProvider$StatusProviderImpl.checkHints(StatusProvider.java:130)
org.netbeans.modules.maven.hints.pom.StatusProvider$StatusProviderImpl.access$000(StatusProvider.java:100)
org.netbeans.modules.maven.hints.pom.StatusProvider$StatusProviderImpl$1$1.run(StatusProvider.java:114)
org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1418)
org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:1957)
Comment 2 mfu 2010-09-15 21:27:49 UTC
Can confirm this on Ubuntu 10.04 AMD64 using Sun Java "1.6.0_20" and Netbeans 6.9.1.

I've only experienced this after saving a maven pom.xml file.
Comment 3 tbb 2010-09-15 22:35:03 UTC
This issue also occurs, while switching to the GUI-Editor, if some other source files are open. The initialsation (loading) of the editor starts and ... thats it.

Workaround:
1. Restart NetBeans (losing all changes)
2. Close all opened files
3. Restart NetBeans again
4. Open the GUI-Editor

It seems NetBeans 6.9.X has a serious bug in its thread handling.

In 6.8 this issue does not occur.
Comment 4 Jesse Glick 2010-09-16 15:30:33 UTC

*** This bug has been marked as a duplicate of bug 187615 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo