Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 18907 - Null Pointer Exception on Startup
Null Pointer Exception on Startup
Status: RESOLVED DUPLICATE of bug 18714
Product: contrib
Classification: Unclassified
Component: RemoteFS
3.x
PC Windows 3.1/NT
: P3 (vote)
: TBD
Assigned To: remotefs@contrib
remotefs@contrib
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-21 17:47 UTC by Gary Hessler
Modified: 2002-07-19 15:25 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gary Hessler 2001-12-21 17:47:26 UTC
While starting up the IDE, get the following error:

*********** Exception occurred ************
Fri Dec 21 10:29:38 MST 2001: java.lang.NullPointerException: <no message>
java.lang.NullPointerException
	at org.netbeans.modules.remotefs.ftpfs.FTPFileSystem.ftpSettingsChanged
(FTPFileSystem.java:86)
	at org.netbeans.modules.remotefs.ftpfs.FTPFileSystem$1.propertyChange
(FTPFileSystem.java:67)
	at java.beans.PropertyChangeSupport.firePropertyChange
(PropertyChangeSupport.java:152)
	at org.openide.util.SharedClassObject.firePropertyChange
(SharedClassObject.java:366)
	at org.openide.options.SystemOption.firePropertyChange
(SystemOption.java:87)
	at org.openide.options.SystemOption.readExternal(SystemOption.java:288)
	at org.openide.util.SharedClassObject$WriteReplace.readObject
(SharedClassObject.java:700)
	at java.lang.reflect.Method.invoke(Native Method)
	at java.io.ObjectInputStream.invokeObjectReader
(ObjectInputStream.java:2214)
	at java.io.ObjectInputStream.inputObject(ObjectInputStream.java:1411)
	at java.io.ObjectInputStream.readObject(ObjectInputStream.java:386)
	at java.io.ObjectInputStream.readObject(ObjectInputStream.java:236)
	at org.openide.loaders.XMLSettingsSupport$SettingsRecognizer.readSerial
(XMLSettingsSupport.java:400)
	at 
org.openide.loaders.XMLSettingsSupport$SettingsRecognizer.instanceCreate
(XMLSettingsSupport.java:430)
	at 
org.openide.loaders.InstanceDataObject$SettingsInstance.instanceCreate
(InstanceDataObject.java:1204)
[catch] at org.openide.loaders.InstanceDataObject.instanceCookieChanged
(InstanceDataObject.java:169)
	at org.openide.loaders.InstanceDataObject.access$1000
(InstanceDataObject.java:67)
	at org.openide.loaders.InstanceDataObject$SettingsInstance.fileChanged
(InstanceDataObject.java:1606)
	at org.openide.util.WeakListener$FileChange.fileChanged
(WeakListener.java:406)
	at org.openide.filesystems.FileObject$ED.dispatch(FileObject.java:630)
	at org.openide.filesystems.EventControl.invokeDispatchers
(EventControl.java:161)
	at org.openide.filesystems.EventControl.exitAtomicAction
(EventControl.java:139)
	at org.openide.filesystems.EventControl.runAtomicAction
(EventControl.java:91)
	at org.openide.filesystems.FileSystem.runAtomicAction
(FileSystem.java:388)
	at org.netbeans.core.projects.SessionManager.setProjectLayer
(SessionManager.java:127)
	at org.netbeans.modules.projects.PSupport.projectOpen(PSupport.java:203)
	at org.netbeans.core.NbProjectOperation.setProject
(NbProjectOperation.java:141)
	at org.netbeans.core.NbProjectOperation.setOpeningProject
(NbProjectOperation.java:199)
	at org.netbeans.core.NbProjectOperation.openOrCreateProject
(NbProjectOperation.java:186)
	at org.netbeans.core.NonGui.run(NonGui.java:535)
	at org.netbeans.core.Main.run(Main.java:215)
	at org.openide.TopManager.initializeTopManager(TopManager.java:120)
	at org.openide.TopManager.getDefault(TopManager.java:81)
	at org.netbeans.core.Main.main(Main.java:324)
	at org.netbeans.core.TopThreadGroup.run(TopThreadGroup.java:87)
	at java.lang.Thread.run(Thread.java:484)
Comment 1 Jan Zajicek 2002-01-02 09:08:37 UTC
It is a duplicate.

*** This issue has been marked as a duplicate of 18714 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo