Bug 18714 - NullPointerException when loading module FTP fs
NullPointerException when loading module FTP fs
Status: RESOLVED FIXED
Product: contrib
Classification: Unclassified
Component: RemoteFS
3.x
PC Windows 3.1/NT
: P2 (vote)
: 3.x
Assigned To: remotefs@contrib
remotefs@contrib
:
: 18711 18907 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-17 10:13 UTC by Martin Ryzl
Modified: 2002-01-02 14:15 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Ryzl 2001-12-17 10:13:41 UTC
Originally reported as 18689

Sun Dec 16 12:24:22 IST 2001: java.lang.NullPointerException: <no message>
java.lang.NullPointerException
        at org.netbeans.modules.remotefs.ftpfs.FTPFileSystem.ftpSettingsChanged
(FTPFileSystem.java:86)
        at org.netbeans.modules.remotefs.ftpfs.FTPFileSystem$1.propertyChange
(FTPFileSystem.java:67)
        at java.beans.PropertyChangeSupport.firePropertyChange
(PropertyChangeSupport.java:152)
        at org.openide.util.SharedClassObject.firePropertyChange
(SharedClassObject.java:366)
        at org.openide.options.SystemOption.firePropertyChange
(SystemOption.java:87)
        at org.openide.options.SystemOption.readExternal(SystemOption.java:288)
        at org.openide.util.SharedClassObject$WriteReplace.readObject
(SharedClassObject.java:700)
        at java.lang.reflect.Method.invoke(Native Method)
        at java.io.ObjectInputStream.invokeObjectReader
(ObjectInputStream.java:2214)
        at java.io.ObjectInputStream.inputObject(ObjectInputStream.java:1411)
        at java.io.ObjectInputStream.readObject(ObjectInputStream.java:386)
        at java.io.ObjectInputStream.readObject(ObjectInputStream.java:236)
        at org.openide.loaders.XMLSettingsSupport$SettingsRecognizer.readSerial
(XMLSettingsSupport.java:400)
        at 
org.openide.loaders.XMLSettingsSupport$SettingsRecognizer.instanceCreate
(XMLSettingsSupport.java:430)
        at 
org.openide.loaders.InstanceDataObject$SettingsInstance.instanceCreate
(InstanceDataObject.java:1204)
        at org.openide.loaders.InstanceDataObject.instanceCookieChanged
(InstanceDataObject.java:169)
        at org.openide.loaders.InstanceDataObject.access$1000
(InstanceDataObject.java:67)
        at org.openide.loaders.InstanceDataObject$2.propertyChange
(InstanceDataObject.java:1346)
        at org.openide.util.WeakListener$PropertyChange.propertyChange
(WeakListener.java:325)
        at org.openide.modules.ModuleInfo.firePropertyChange
(ModuleInfo.java:120)
        at org.netbeans.core.modules.Module.firePropertyChange0(Module.java:677)
        at org.netbeans.core.modules.ChangeFirer$DoFiring.run
(ChangeFirer.java:113)
        at org.openide.util.Mutex.readAccess(Mutex.java:241)
[catch] at org.netbeans.core.modules.ChangeFirer.run(ChangeFirer.java:91)
Comment 1 hary 2001-12-17 10:56:32 UTC
*** Issue 18711 has been marked as a duplicate of this issue. ***
Comment 2 Jan Zajicek 2002-01-02 09:08:32 UTC
Increasing prio, too much reports of this problem.
Comment 3 Jan Zajicek 2002-01-02 09:08:37 UTC
*** Issue 18907 has been marked as a duplicate of this issue. ***
Comment 4 Martin Ryzl 2002-01-02 14:15:27 UTC
fixed in main trunk together with another problems - NPEs, problem
with localized dates and removed client after writeObject has been called.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo