Bug 188440 - Direct support for secondary artifacts
Direct support for secondary artifacts
Status: RESOLVED FIXED
Product: projects
Classification: Unclassified
Component: Maven
6.x
All All
: P2 (vote)
: 7.1
Assigned To: Jesse Glick
issues@projects
:
: 154931 200802 (view as bug list)
Depends on: 204546
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-07 11:22 UTC by Antonin Nebuzelsky
Modified: 2012-03-30 21:59 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Antonin Nebuzelsky 2010-07-07 11:22:48 UTC
Secondary artifacts are now only listed in the artifact details view, without a possibility to add dependencies on some of them from the UI.

The user needs to add manually several entries in his pom, with <classifier> parameter for each secondary artifact dependency.

An example: net.sourceforge.saxon : saxon, 9.1.0.8 and its s9api secondary artifact.
Comment 1 Jesse Glick 2010-08-24 20:44:00 UTC
Beware that for test-to-test dependencies you should use <type>test-jar</> rather than <classifier>tests</>: http://maven.apache.org/guides/mini/guide-attached-tests.html
Comment 2 Jesse Glick 2011-08-25 18:31:26 UTC
core-main #09b5b994b3d2
Comment 3 Jesse Glick 2011-08-25 18:53:20 UTC
(In reply to comment #1)
> for test-to-test dependencies you should use <type>test-jar</>
> rather than <classifier>tests</>

Appears to be obsolete advice: http://jira.codehaus.org/browse/MNG-4056
Comment 4 Quality Engineering 2011-08-26 14:40:41 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/09b5b994b3d2
User: Jesse Glick <jglick@netbeans.org>
Log: #188440: Direct support for secondary artifacts
Comment 5 Jesse Glick 2012-02-22 23:37:55 UTC
*** Bug 154931 has been marked as a duplicate of this bug. ***
Comment 6 Jesse Glick 2012-03-30 21:59:09 UTC
*** Bug 200802 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo