Bug 187980 - An unexpected exception happened in thread AWT-EventQueue-0 java.lang.NullPointerException when install Netbeans
An unexpected exception happened in thread AWT-EventQueue-0 java.lang.NullPoi...
Status: RESOLVED WONTFIX
Product: installer
Classification: Unclassified
Component: JDK bundle
6.x
PC Windows 7 x64
: P1 (vote)
: 6.x
Assigned To: Yulia Novozhilova
issues@installer
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-23 08:26 UTC by iamzifei
Modified: 2010-06-28 09:25 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
log for nullpointer error when installing (42.53 KB, application/octet-stream)
2010-06-23 08:31 UTC, iamzifei
Details

Note You need to log in before you can comment on or make changes to this bug.
Description iamzifei 2010-06-23 08:26:55 UTC
When try to install Netbeans 6.9, I got the following error after I accept agreement.
An unexpected exception happened in thread AWT-EventQueue-0
java.lang.NullPointerException
null

================================================================================
[2010-06-23 17:30:18.856]: ... use Java that is already selected for the product: C:\Program Files (x86)\Java\jdk1.6.0_20
[2010-06-23 17:30:18.924]: An unexpected exception happened in thread AWT-EventQueue-0
[2010-06-23 17:30:18.925]: java.lang.NullPointerException
[2010-06-23 17:30:18.925]: 	at sun.awt.shell.Win32ShellFolder2$7.call(Unknown Source)
[2010-06-23 17:30:18.925]: 	at sun.awt.shell.Win32ShellFolder2$7.call(Unknown Source)
[2010-06-23 17:30:18.925]: 	at sun.awt.shell.Win32ShellFolderManager2$ComInvoker.invoke(Unknown Source)
[2010-06-23 17:30:18.925]: 	at sun.awt.shell.ShellFolder.invoke(Unknown Source)
[2010-06-23 17:30:18.925]: 	at sun.awt.shell.ShellFolder.invoke(Unknown Source)
[2010-06-23 17:30:18.925]: 	at sun.awt.shell.Win32ShellFolder2.getFileSystemPath(Unknown Source)
[2010-06-23 17:30:18.925]: 	at sun.awt.shell.Win32ShellFolder2.access$300(Unknown Source)
[2010-06-23 17:30:18.925]: 	at sun.awt.shell.Win32ShellFolder2$11.call(Unknown Source)
[2010-06-23 17:30:18.925]: 	at sun.awt.shell.Win32ShellFolder2$11.call(Unknown Source)
[2010-06-23 17:30:18.925]: 	at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
[2010-06-23 17:30:18.925]: 	at java.util.concurrent.FutureTask.run(Unknown Source)
[2010-06-23 17:30:18.925]: 	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
[2010-06-23 17:30:18.925]: 	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
[2010-06-23 17:30:18.925]: 	at sun.awt.shell.Win32ShellFolderManager2$ComInvoker$3.run(Unknown Source)
[2010-06-23 17:30:18.925]: 	at java.lang.Thread.run(Unknown Source)
[2010-06-23 17:30:18.926]: ... show message dialog
[2010-06-23 17:30:18.926]:     title: Critical Error
[2010-06-23 17:30:18.926]:     message: An unexpected exception happened in thread AWT-EventQueue-0
[2010-06-23 17:30:18.926]:     
[2010-06-23 17:30:18.926]:     Exception:
[2010-06-23 17:30:18.926]:       java.lang.NullPointerException:
[2010-06-23 17:30:18.926]:       null
[2010-06-23 17:30:18.926]:     






I tried old version of Netbeans as well and the same happens.

I also uninstalled my JDK and downloaded a Netbeans(6.9) with JDK bundle (JDK6U20), then I got another error said:
java.io.IOException: Could not get shell folder ID list

================================================================================
[2010-06-23 17:37:21.011]: ... product registry initialization complete
[2010-06-23 17:37:21.011]: exiting -- org.netbeans.installer.wizard.components.actions.InitializeRegistryAction.execute():72
[2010-06-23 17:37:21.639]: ... checking if JDK 1.6.0_20 is already installed
[2010-06-23 17:37:21.639]: ... cannot find key for this Java
[2010-06-23 17:37:21.640]: ... checking if JDK 1.6.0_20 is already installed
[2010-06-23 17:37:21.640]: ... cannot find key for this Java
[2010-06-23 17:37:21.786]: ... loading registry from resource:data/registry.xml
[2010-06-23 17:37:21.802]: entering -- org.netbeans.installer.product.Registry.loadProductRegistry():987
[2010-06-23 17:37:21.802]: validating previous installations
[2010-06-23 17:37:21.803]: ... validating installations finished
[2010-06-23 17:37:21.803]: exiting -- org.netbeans.installer.product.Registry.loadProductRegistry():987
[2010-06-23 17:37:21.803]: ... checking if JDK 1.6.0_20 is already installed
[2010-06-23 17:37:21.803]: ... cannot find key for this Java
[2010-06-23 17:37:21.803]: ... use Java from the first item in the overall list: C:\Program Files (x86)\Java\jdk1.6.0_20
[2010-06-23 17:37:21.803]: ... use Java that is already selected for the product: C:\Program Files (x86)\Java\jdk1.6.0_20
[2010-06-23 17:37:48.251]: An unexpected exception happened in thread AWT-EventQueue-0
[2010-06-23 17:37:48.252]: java.lang.RuntimeException: java.io.IOException: Could not get shell folder ID list
[2010-06-23 17:37:48.252]: 	at sun.awt.shell.Win32ShellFolderManager2$ComInvoker.invoke(Unknown Source)
[2010-06-23 17:37:48.253]: 	at sun.awt.shell.Win32ShellFolder2.getFileSystemPath(Unknown Source)
[2010-06-23 17:37:48.253]: 	at sun.awt.shell.Win32ShellFolder2.composePathForCsidl(Unknown Source)
[2010-06-23 17:37:48.253]: 	at sun.awt.shell.Win32ShellFolder2.<init>(Unknown Source)
[2010-06-23 17:37:48.253]: 	at sun.awt.shell.Win32ShellFolderManager2.getNetwork(Unknown Source)
[2010-06-23 17:37:48.253]: 	at sun.awt.shell.Win32ShellFolder2$7.call(Unknown Source)
[2010-06-23 17:37:48.253]: 	at sun.awt.shell.Win32ShellFolder2$7.call(Unknown Source)
[2010-06-23 17:37:48.253]: 	at sun.awt.shell.Win32ShellFolderManager2$ComInvoker.invoke(Unknown Source)
[2010-06-23 17:37:48.253]: 	at sun.awt.shell.Win32ShellFolder2.getFileSystemPath(Unknown Source)
[2010-06-23 17:37:48.254]: 	at sun.awt.shell.Win32ShellFolder2.access$300(Unknown Source)
[2010-06-23 17:37:48.254]: 	at sun.awt.shell.Win32ShellFolder2$11.call(Unknown Source)
[2010-06-23 17:37:48.254]: 	at sun.awt.shell.Win32ShellFolder2$11.call(Unknown Source)
[2010-06-23 17:37:48.254]: 	at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
[2010-06-23 17:37:48.254]: 	at java.util.concurrent.FutureTask.run(Unknown Source)
[2010-06-23 17:37:48.254]: 	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
[2010-06-23 17:37:48.254]: 	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
[2010-06-23 17:37:48.254]: 	at sun.awt.shell.Win32ShellFolderManager2$ComInvoker$3.run(Unknown Source)
[2010-06-23 17:37:48.254]: 	at java.lang.Thread.run(Unknown Source)
[2010-06-23 17:37:48.254]: Caused by: java.io.IOException: Could not get shell folder ID list
[2010-06-23 17:37:48.254]: 	at sun.awt.shell.Win32ShellFolder2.getFileSystemPath0(Native Method)
[2010-06-23 17:37:48.254]: 	at sun.awt.shell.Win32ShellFolder2.access$900(Unknown Source)
[2010-06-23 17:37:48.254]: 	at sun.awt.shell.Win32ShellFolder2$8.call(Unknown Source)
[2010-06-23 17:37:48.254]: 	at sun.awt.shell.Win32ShellFolder2$8.call(Unknown Source)
[2010-06-23 17:37:48.254]: 	... 18 more
[2010-06-23 17:37:48.255]: ... show message dialog
[2010-06-23 17:37:48.255]:     title: Critical Error
[2010-06-23 17:37:48.255]:     message: An unexpected exception happened in thread AWT-EventQueue-0
[2010-06-23 17:37:48.255]:     
[2010-06-23 17:37:48.255]:     Exception:
[2010-06-23 17:37:48.255]:       java.lang.RuntimeException:
[2010-06-23 17:37:48.255]:       java.io.IOException: Could not get shell folder ID list
[2010-06-23 17:37:48.255]:
Comment 1 iamzifei 2010-06-23 08:31:55 UTC
Created attachment 100347 [details]
log for nullpointer error when installing
Comment 2 Yulia Novozhilova 2010-06-23 09:33:32 UTC
This is jdk bug. According to http://netbeans.org/bugzilla/show_bug.cgi?id=186615 reverting to 1.6.0_18 should help.

*** This bug has been marked as a duplicate of bug 186615 ***
Comment 3 dlipin 2010-06-23 10:19:21 UTC
"Could not get shell folder ID list" bug is this one (fixed in 6u18):
http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6544857

We'll need to update bundled JRE to 6u20 (or 21) with the next NB/JDK bundle.
Comment 4 iamzifei 2010-06-23 11:51:03 UTC
(In reply to comment #2)
> This is jdk bug. According to
> http://netbeans.org/bugzilla/show_bug.cgi?id=186615 reverting to 1.6.0_18
> should help.
> 
> *** This bug has been marked as a duplicate of bug 186615 ***



Actually I've done this action before I post here and the problem is still there.
Comment 5 dlipin 2010-06-23 12:34:46 UTC
Does JFileChooser demo works fine on your system?

"C:\Program Files (x86)\Java\jdk1.6.0_20\bin\java.exe" -jar "C:\Program Files (x86)\Java\jdk1.6.0_20\demo\jfc\FileChooserDemo\filechooserdemo.jar"
Comment 6 iamzifei 2010-06-23 12:56:15 UTC
(In reply to comment #5)
> Does JFileChooser demo works fine on your system?
> 
> "C:\Program Files (x86)\Java\jdk1.6.0_20\bin\java.exe" -jar "C:\Program Files
> (x86)\Java\jdk1.6.0_20\demo\jfc\FileChooserDemo\filechooserdemo.jar"

Seems not, however I'm using jdk1.6.0_18, I run this in Windows7 cmd and got this:

C:\Users\Zifei>"C:\Program Files (x86)\Java\jdk1.6.0_18\bin\java.exe" -jar "C:\P
rogram Files (x86)\Java\jdk1.6.0_18\demo\jfc\FileChooserDemo\FileChooserDemo.jar
"
Exception in thread "main" java.lang.NullPointerException
        at sun.awt.shell.Win32ShellFolder2$7.call(Win32ShellFolder2.java:548)
        at sun.awt.shell.Win32ShellFolder2$7.call(Win32ShellFolder2.java:545)
        at sun.awt.shell.Win32ShellFolderManager2$ComInvoker.invoke(Win32ShellFo
lderManager2.java:511)
        at sun.awt.shell.ShellFolder.invoke(ShellFolder.java:399)
        at sun.awt.shell.ShellFolder.invoke(ShellFolder.java:385)
        at sun.awt.shell.Win32ShellFolder2.getFileSystemPath(Win32ShellFolder2.j
ava:545)
        at sun.awt.shell.Win32ShellFolder2.access$300(Win32ShellFolder2.java:55)

        at sun.awt.shell.Win32ShellFolder2$11.call(Win32ShellFolder2.java:725)
        at sun.awt.shell.Win32ShellFolder2$11.call(Win32ShellFolder2.java:716)
        at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
        at java.util.concurrent.FutureTask.run(FutureTask.java:138)
        at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExec
utor.java:886)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor
.java:908)
        at sun.awt.shell.Win32ShellFolderManager2$ComInvoker$3.run(Win32ShellFol
derManager2.java:480)
        at java.lang.Thread.run(Thread.java:619)
Comment 7 iamzifei 2010-06-24 04:13:20 UTC
(In reply to comment #4)
> (In reply to comment #2)
> > This is jdk bug. According to
> > http://netbeans.org/bugzilla/show_bug.cgi?id=186615 reverting to 1.6.0_18
> > should help.
> > 
> > *** This bug has been marked as a duplicate of bug 186615 ***
> 
> 
> 
> Actually I've done this action before I post here and the problem is still
> there.

I also tried JDK6U10 and even JDK5U22 but all got the same errors with both Netbeans6.8 or Netbeans6.9 installer. I guess there're maybe something wrong with my windows registry?
Comment 8 dlipin 2010-06-28 09:25:36 UTC
As the issue is reproducible with FileChooser demo, then it is likely the JDK bug which we cannot do anything with.

Please report the it to 
http://bugreport.sun.com/bugreport/index.jsp
and make a note at this issue about the number of the bug submitted (please note at that bug that you have problems with FileChooser demo).

Thanks.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo