Bug 186615 - NullPointerException at sun.awt.shell.Win32ShellFolder2.pidlsEqual
NullPointerException at sun.awt.shell.Win32ShellFolder2.pidlsEqual
Status: CLOSED WONTFIX
Product: platform
Classification: Unclassified
Component: JDK Problems
6.x
All All
: P3 (vote)
: 6.x
Assigned To: issues@platform
issues@platform
EXCEPTIONS_REPORT, jdk_bug_6940843
:
: 183357 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-24 15:18 UTC by Egor Ushakov
Modified: 2011-06-09 19:31 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (946 bytes, text/plain)
2010-05-24 15:18 UTC, Egor Ushakov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Egor Ushakov 2010-05-24 15:18:10 UTC
Build: NetBeans IDE Dev (Build 201005192201)
VM: Java HotSpot(TM) 64-Bit Server VM, 16.3-b01, Java(TM) SE Runtime Environment, 1.6.0_20-b02
OS: Windows 7

User Comments:
gorrus: Called "Open file"

GUEST: tried to open a file with "Open File..."




Stacktrace: 
java.lang.NullPointerException
   at sun.awt.shell.Win32ShellFolder2.pidlsEqual(Win32ShellFolder2.java:498)
   at sun.awt.shell.Win32ShellFolder2.equals(Win32ShellFolder2.java:491)
   at org.openide.filesystems.FileUtil.toFileObject(FileUtil.java:993)
   at org.netbeans.modules.cnd.utils.MIMESupport.getFileMIMEType(MIMESupport.java:86)
   at org.netbeans.modules.cnd.utils.filters.HeaderSourceFileFilter.accept(HeaderSourceFileFilter.java:73)
   at org.netbeans.modules.cnd.utils.filters.CndOpenFileDialogFilter$Adapter.accept(CndOpenFileDialogFilter.java:91)
Comment 1 Egor Ushakov 2010-05-24 15:18:14 UTC
Created attachment 99397 [details]
stacktrace
Comment 2 Alexander Simon 2010-05-24 15:51:11 UTC
http://www.dbvis.com/forum/message.jspa?messageID=10866
Comment 3 Alexander Simon 2010-05-24 15:53:45 UTC
See:
http://www.dbvis.com/forum/message.jspa?messageID=10866
Comment 4 Jaroslav Tulach 2010-05-24 18:22:22 UTC
Justify priority in case you believe this is not P3.
Comment 5 Jaroslav Tulach 2010-06-15 21:15:20 UTC
We are not going to fix it. To quote from the above URL:

> I reverted to 1.6.0_18, and everything seems OK now. Thanks.
> Hopefully, the guys at Oracle \[sic\] will fix this soon. :)

Tonda can probably make sure that the issue is properly reported to JDK team.
Comment 6 Antonin Nebuzelsky 2010-06-16 11:54:07 UTC
This bug is similar to issue 183407. Both issues are related to a bug in jdk #6940843. This JDK bug has already been escalated and the fix is currently targeted at 6u21.
Comment 7 Yulia Novozhilova 2010-06-23 09:33:32 UTC
*** Bug 187980 has been marked as a duplicate of this bug. ***
Comment 8 Marian Mirilovic 2011-06-09 19:30:38 UTC
*** Bug 183357 has been marked as a duplicate of this bug. ***
Comment 9 Marian Mirilovic 2011-06-09 19:31:36 UTC
Fixed in JDk6u21


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo