Bug 187657 - Deadlock between OpenProjectList$RecentProjectList & OpenProjectList.class
Deadlock between OpenProjectList$RecentProjectList & OpenProjectList.class
Status: RESOLVED FIXED
Product: projects
Classification: Unclassified
Component: Generic Infrastructure
7.0
All All
: P2 (vote)
: 7.0
Assigned To: Jesse Glick
issues@projects
: RANDOM, THREAD
: 189710 190922 (view as bug list)
Depends on: 191844
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-16 14:27 UTC by Alexander Simon
Modified: 2010-12-02 14:40 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
IDE log with thread dump (86.97 KB, text/plain)
2010-06-16 14:27 UTC, Alexander Simon
Details
Patch in progress (31.85 KB, patch)
2010-10-26 14:32 UTC, Jesse Glick
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Simon 2010-06-16 14:27:22 UTC
Created attachment 100135 [details]
IDE log with thread dump

Found one Java-level deadlock:
=============================
"org.netbeans.modules.project.ui.actions.ActiveConfigAction":
  waiting to lock monitor 0x09e5b1cc (object 0xcd4afba8, a java.lang.Class),
  which is held by "Opening projects"
"Opening projects":
  waiting to lock monitor 0x099d60ec (object 0x642552e0, a org.netbeans.modules.project.ui.OpenProjectList$RecentProjectList),
  which is held by "Default RequestProcessor"
"Default RequestProcessor":
  waiting to lock monitor 0x09e5b1cc (object 0xcd4afba8, a java.lang.Class),
  which is held by "Opening projects"
Comment 1 Jesse Glick 2010-06-16 14:33:07 UTC
Need to consolidate monitors I guess.
Comment 2 Jesse Glick 2010-08-20 12:48:14 UTC
*** Bug 189710 has been marked as a duplicate of this bug. ***
Comment 3 Jesse Glick 2010-10-12 16:28:26 UTC
*** Bug 190922 has been marked as a duplicate of this bug. ***
Comment 4 Vladimir Voskresensky 2010-10-12 18:07:19 UTC
it's already the 3rd... shouldn't be P2?
Comment 5 Jesse Glick 2010-10-12 18:17:25 UTC
If it seems to be common then yes.
Comment 6 Jesse Glick 2010-10-26 14:32:22 UTC
Created attachment 102645 [details]
Patch in progress

Unit tests failing, may need to be rewritten.
Comment 7 Jesse Glick 2010-10-30 19:14:40 UTC
core-main #2160fbaa2114
Comment 8 Quality Engineering 2010-11-01 03:58:25 UTC
Integrated into 'main-golden', will be available in build *201011010000* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/2160fbaa2114
User: Jesse Glick <jglick@netbeans.org>
Log: #187657: deadlock between OpenProjectList$RecentProjectList & OpenProjectList.class.
Simplify threading in this class by using ProjectManager.mutex consistently throughout.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo