Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 186660 - 502 Proxy Error ... and I am not able to Logout
502 Proxy Error ... and I am not able to Logout
Status: RESOLVED FIXED
Product: www
Classification: Unclassified
Component: Admin
6.x
PC Linux
: P1 (vote)
: TBD
Assigned To: Marco Walther
Admins
kenai
:
: 197854 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-25 12:43 UTC by Marian Mirilovic
Modified: 2011-11-15 01:08 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
screenshot (95.60 KB, image/png)
2010-05-25 12:43 UTC, Marian Mirilovic
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marian Mirilovic 2010-05-25 12:43:45 UTC
Created attachment 99433 [details]
screenshot

Pushed Loged out and got 
"503 Proxy Error" for: https://netbeans.org/people/logout?original_uri=http%3A%2F%2Fnetbeans.org%2Fbugzilla%2Frelogin.cgi

tried another url (let's say previous one) ... I am still loggedin 

See attached screenshot
Comment 1 leawang 2010-05-26 14:31:57 UTC
Do you still experience this today?  Thanks.
Comment 2 Marian Mirilovic 2010-05-26 14:50:17 UTC
I tried it just recently and it works as expected - for now.
Comment 3 leawang 2010-05-26 14:57:22 UTC
We had a new deployment last night. The machine resources have stayed flat so far.  Let's see how it goes next couple days.  Thanks.
Comment 4 Martin Fousek 2010-06-23 12:47:53 UTC
Reproduced again by one of my colleagues with Win Vista and FF 3.6.3.
He wasn't able to login because of PROXY ERROR. It was 23/06 at 14:43 PRG time - login name was "jpospisil".
Helped deleting of domain cookies as usually. 

BTH also another users on @nb mailing list write about troubles by logging in or logout on the site. I hope that could help some information from today logs.
Comment 5 Jan Pirek 2011-03-30 06:53:47 UTC
Hello,
we just have another round of reports on this issue from users from yesterday. 

Still the very same problem - login pages give user 502 proxy error, Date: 30 March 2011 2:19:39 AM AEDT

Can you please investigate and let us know what is causing that?

honza
Comment 6 Jesse Glick 2011-03-30 14:31:22 UTC
Was happening to me yesterday as well; was logged out (for no clear reason) and was getting 502s when I tried to log back in. Deleting all my cookies from netbeans.org fixed the problem.

I am pretty sure this has been reported at least once before, but there was no real resolution other than a recommendation to delete cookies. I thought that the issue was that certain actions in BugZilla respond with a very long Set-Cookie value such as for BUGLIST, or perhaps just a lot of cookies such as VERSION-${componentName}, and something in Kenai infrastructure has a low fixed limit on Cookie headers it accepts before it crashes. However BZ does seem to correctly set Path: /bugzilla/ which should prevent such cookies from being passed to e.g. /people/login so perhaps some non-BZ-related cookies are causing the issue.
Comment 7 Marco Walther 2011-03-30 16:00:15 UTC
The cookie path for BZ cookies was changed with the deployment yesterday. I believe it really was (mostly) the BUGLIST cookie that could create problems for GlassFish:-( It's actually the sum of all cookies >4k, but BUGLIST is by far the biggest normally.

But since I can't control the cookies out there in the browsers of different users, I'll leave this open for a bit longer.
Comment 8 Jesse Glick 2011-03-30 16:48:28 UTC
If the server cannot handle that many cookies, is there some way for it to detect this early and fail with a helpful HTML page that tells you how to work around the problem? Otherwise your assumption is just that the server is down, and to wait a few hours.
Comment 9 tomwheeler 2011-04-19 16:00:51 UTC
I agree with Jesse.  While there is a workaround, I think very few people know about it and deleting my cookies is not something even an experienced person would instinctively try.  As evidence, look at issue #197854.

Kenai team: When can we expect this to get fixed?
Comment 10 Jesse Glick 2011-04-19 22:29:04 UTC
*** Bug 197854 has been marked as a duplicate of this bug. ***
Comment 11 Jiri Kovalsky 2011-04-21 14:20:17 UTC
I am really curious what the Kenai's team (consisting of 1 person :( will be.
Comment 12 Marco Walther 2011-04-21 18:13:02 UTC
Actually, the Kenai team are still three people. But the problem is, I'm the only one who does not fear to touch all parts:-(

This particular problem is either a Bugzilla problem, or a Glassfish problem or a JRuby problem or a Rails problem:-(

The little specs about HTTP cookies say that clients and servers should handle cokkies with a combined size >= 4k. But BZ seems to create very long BUGLIST cookies when it wants to. That's the BZ problem part:-( But we sit on a EndOfLived BZ branch and nobody has time to upgrade:-(

Somewhere between GF/JRuby & Rails things fall over when the cookies get too large. But so far I don't know where:-( And all pieces are already very dated. So there is not much hope for help either:-(

Welcome to the fruits of two years under-staffing:-(
Comment 13 _ tboudreau 2011-05-16 17:01:58 UTC
Is there any kind of web proxy being used in front of the site, where you could just script something to strip out overly large buglist cookies from the HTTP headers at the front door, before they get passed along to whatever chokes on them?
Comment 14 Marco Walther 2011-11-15 01:08:52 UTC
Is this still a problem or was setting the cookie path to /bugzilla/ good here?


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo