Bug 186604 - Maven Netbeans Application wizard in FoD has wrong dependencies
Maven Netbeans Application wizard in FoD has wrong dependencies
Status: RESOLVED WORKSFORME
Product: projects
Classification: Unclassified
Component: Maven
6.x
All All
: P2 (vote)
: TBD
Assigned To: David Simonek
issues@projects
EXCEPTIONS_REPORT
: ERGONOMICS, RANDOM
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-24 13:05 UTC by Jaroslav Pospisil
Modified: 2010-05-26 12:49 UTC (History)
8 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jaroslav Pospisil 2010-05-24 13:05:54 UTC
This bug was originally marked as duplicate of bug 170309, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE Dev (Build 201005181742)
VM: Java HotSpot(TM) Client VM, 16.3-b01, Java(TM) SE Runtime Environment, 1.6.0_20-b02
OS: Windows Vista

User Comments:
GUEST: First start after clean installation, tried to create C++ project with existing makefile

jpospisil: Started new Maven Netbeans Application wizard - NPE during initial activation of components

martinhavle: Occured when creating new php application from remote server at step 2 - Finnding feature (first thing after clean installation of IDE).

pjiricka: Creating a web project.

pcw: waiting for web / javaee to activate on first startup.




Stacktrace: 
java.lang.NullPointerException: Send us the messages.log please!
   at org.netbeans.modules.ide.ergonomics.newproject.DescriptionStep.waitForDelegateWizard(DescriptionStep.java:264)
   at org.netbeans.modules.ide.ergonomics.newproject.DescriptionStep.access$000(DescriptionStep.java:87)
   at org.netbeans.modules.ide.ergonomics.newproject.DescriptionStep$1.call(DescriptionStep.java:110)
   at org.netbeans.modules.ide.ergonomics.newproject.DescriptionStep$1.call(DescriptionStep.java:106)
   at org.netbeans.modules.ide.ergonomics.fod.ConfigurationPanel$2$1.run(ConfigurationPanel.java:213)
   at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
Comment 1 Jaroslav Pospisil 2010-05-24 13:26:06 UTC
Issue is reproducible only from clean IDE - if I create any other project
previously (Maven Quickstart Project,for example),nothing bad happens.
Comment 2 Jaroslav Pospisil 2010-05-24 13:27:34 UTC
This issue has also the same exception log as issue 170039,already fixed.
Comment 3 Tomas Pavek 2010-05-24 14:12:03 UTC
Tried the last mentioned steps:
> Started IDE with clean userdir and invoked new Maven Netbeans
> App - NPE occured during initial activation of components.
but it works for me in 201005202201 RC build, no NPE.

BTW the correct number of the other issue issue is issue 170309.
Comment 4 Jaroslav Tulach 2010-05-24 14:14:43 UTC
This is an excerpt from messages.log file attached to:
http://statistics.netbeans.org/exceptions/exception.do?id=392892

WARNING [org.openide.filesystems.Ordering]: Found same position 400 for both Templates/Project/Samples/Enterprise and Templates/Project/Samples/J2ME_MIDP
INFO [org.netbeans.core.startup.NbEvents]: Turning on modules:
	org.netbeans.modules.apisupport.harness [1.22 201005181742]
	org.netbeans.modules.apisupport.crudsample [1.2 201005181742]
	org.netbeans.modules.apisupport.tc.cobertura [1.3 201005181742]
	org.netbeans.modules.apisupport.ant [2.39 201005181742]
	org.netbeans.modules.timers/1 [1.10 201005181742]
	org.netbeans.libs.nbi.engine [1.1 201005181742]
	org.netbeans.modules.apisupport.project/1 [1.42 201005181742]
	org.netbeans.modules.apisupport.feedreader/1 [1.13 201005181742]
	org.netbeans.modules.apisupport.paintapp [1.10 201005181742]
	org.netbeans.libs.nbi.ant [1.2 201005181742]
	org.netbeans.modules.apisupport.installer [1.2 201005181742]
	org.netbeans.modules.apisupport.osgidemo [1.2 201005181742]
	org.netbeans.modules.apisupport.kit [1.9 201005181742]
	org.netbeans.modules.apisupport.refactoring [1.13 201005181742]
WARNING [org.openide.filesystems.Ordering]: Found same position 400 for both Templates/Project/Samples/Enterprise and Templates/Project/Samples/J2ME_MIDP
WARNING [org.netbeans.modules.ide.ergonomics.newproject.DescriptionStep]: There is still wrong interator org.netbeans.modules.ide.ergonomics.newproject.FeatureOnDemandWizardIterator for file object MultiFileObject@10c0ef9[Templates/Project/Maven2/NbApp]
INFO [org.netbeans.modules.ide.ergonomics.fod]: java enabled 3 disabled 5
INFO [org.netbeans.modules.ide.ergonomics.fod]: - org.netbeans.modules.form.kit
INFO [org.netbeans.modules.ide.ergonomics.fod]: - org.netbeans.modules.hibernate
INFO [org.netbeans.modules.ide.ergonomics.fod]: - org.netbeans.modules.j2ee.persistence.kit
INFO [org.netbeans.modules.ide.ergonomics.fod]: - org.netbeans.modules.maven.kit
INFO [org.netbeans.modules.ide.ergonomics.fod]: - org.netbeans.modules.spring.beans
INFO [org.netbeans.modules.ide.ergonomics.fod]: + org.netbeans.modules.ant.kit
INFO [org.netbeans.modules.ide.ergonomics.fod]: + org.netbeans.modules.debugger.jpda.ui
INFO [org.netbeans.modules.ide.ergonomics.fod]: + org.netbeans.modules.java.kit
Comment 5 Jaroslav Tulach 2010-05-24 14:16:45 UTC
The problem seems to be that, when enabling apisupport, associated maven support is not enabled. In case Maven is essential part of apisupport, the apisupport.kit shall have proper dependencies on it. Or at least it shall recommend maven...
Comment 6 Jaroslav Tulach 2010-05-24 14:21:57 UTC
$ hg diff
diff -r eb7fb3108e48 apisupport.kit/manifest.mf
--- a/apisupport.kit/manifest.mf        Fri May 21 21:16:29 2010 +0200
+++ b/apisupport.kit/manifest.mf        Mon May 24 16:21:11 2010 +0200
@@ -2,4 +2,4 @@
 OpenIDE-Module: org.netbeans.modules.apisupport.kit
 OpenIDE-Module-Localizing-Bundle: org/netbeans/modules/apisupport/kit/Bundle.properties
 OpenIDE-Module-Specification-Version: 1.10
-
+OpenIDE-Module-Recommends: org.netbeans.modules.maven.apisupport
$
Comment 7 Jesse Glick 2010-05-24 17:50:20 UTC
While apisupport.kit could recommend maven.apisupport, there is no hard dependency that I know of. Looks like a bug in ergonomics to me.
Comment 8 David Simonek 2010-05-25 14:57:55 UTC
I'm not able to reproduce. Anyway reassigning...
Comment 9 Jaroslav Tulach 2010-05-26 12:36:36 UTC
Dafe, if you cannot reproduce, then the proper resolution is "worksforme", as far as I know.
Comment 10 Jaroslav Pospisil 2010-05-26 12:49:35 UTC
Not reproducible with latest build,so I agree.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo