Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 186280 - Broken javascript refactoring
Broken javascript refactoring
Status: VERIFIED FIXED
Product: web
Classification: Unclassified
Component: Refactoring
6.x
PC Mac OS X
: P1 (vote)
: 6.x
Assigned To: Marek Fukala
issues@web
: REGRESSION
: 186298 187618 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-18 07:55 UTC by Marek Fukala
Modified: 2010-06-22 09:10 UTC (History)
9 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marek Fukala 2010-05-18 07:55:01 UTC
1) create a .js file
2) put: function hello() {}
3) refactor->rename it
=>
SEVERE [global]
java.lang.NullPointerException
	at org.netbeans.modules.css.refactoring.CssRefactoringPluginFactory.createInstance(CssRefactoringPluginFactory.java:63)
	at org.netbeans.modules.refactoring.api.AbstractRefactoring.getPlugins(AbstractRefactoring.java:137)
	at org.netbeans.modules.refactoring.api.AbstractRefactoring.addProgressListener(AbstractRefactoring.java:278)
	at org.netbeans.modules.refactoring.spi.impl.ParametersPanel.showDialog(ParametersPanel.java:468)
	at org.netbeans.modules.refactoring.spi.impl.RefactoringPanel.refresh(RefactoringPanel.java:572)
	at org.netbeans.modules.refactoring.spi.impl.RefactoringPanel.<init>(RefactoringPanel.java:134)
	at org.netbeans.modules.refactoring.spi.ui.UI.openRefactoringUI(UI.java:83)
	at org.netbeans.modules.refactoring.javascript.ui.RefactoringActionsProvider$TextComponentTask.run(RefactoringActionsProvider.java:328)
	at org.netbeans.modules.refactoring.javascript.ui.RefactoringActionsProvider.doRename(RefactoringActionsProvider.java:130)
	at org.netbeans.modules.refactoring.api.impl.ActionsImplementationFactory.doRename(ActionsImplementationFactory.java:83)
Comment 1 Marek Fukala 2010-05-18 07:56:02 UTC
fixed in web-main#428a5eada2de
Comment 2 Marek Fukala 2010-05-18 14:40:06 UTC
*** Bug 186298 has been marked as a duplicate of this bug. ***
Comment 3 Quality Engineering 2010-05-20 06:13:08 UTC
Integrated into 'main-golden', will be available in build *201005192201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/428a5eada2de
User: Marek Fukala <mfukala@netbeans.org>
Log: #186280 -  Broken javascript refactoring
Comment 4 soldatov 2010-05-20 09:59:03 UTC
This bug is fixed (will be fixed) in release69?
Comment 5 Alexandr Scherbatiy 2010-05-20 10:16:30 UTC
I see the issue in netbeans-6.9rc1-201005191833-windows.exe
Comment 6 Alexander Pepin 2010-05-20 13:54:44 UTC
Seems it's not in release 69 clone, someone should start show stopper process.
Comment 7 Alexander Pepin 2010-05-20 14:24:07 UTC
Reopened and escalated to P1 to follow show stopper process.
Comment 8 Marek Fukala 2010-05-24 07:02:59 UTC
transplanted into http://hg.netbeans.org/release69/rev/7916bd68f082
Comment 9 Marek Fukala 2010-05-24 07:05:17 UTC
transplanted into http://hg.netbeans.org/release69/rev/7916bd68f082
Comment 10 Martin Schovanek 2010-06-07 11:56:39 UTC
v.
Comment 11 Marek Fukala 2010-06-22 09:10:49 UTC
*** Bug 187618 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo