Bug 186010 - 62s in org.netbeans.modules.cnd.makeproject.ui.MakeLogicalViewProvider$4.run()
62s in org.netbeans.modules.cnd.makeproject.ui.MakeLogicalViewProvider$4.run()
Status: RESOLVED FIXED
Product: cnd
Classification: Unclassified
Component: Project
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Alexey Vladykin
issues@cnd
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
: 186414 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-12 14:13 UTC by vladdraco
Modified: 2010-05-25 09:50 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (23.43 KB, application/nps)
2010-05-12 14:13 UTC, vladdraco
Details

Note You need to log in before you can comment on or make changes to this bug.
Description vladdraco 2010-05-12 14:13:32 UTC
Build: NetBeans IDE 6.9 Beta (Build 100428-unknown-revn)
VM: Java HotSpot(TM) Client VM, 16.3-b01, Java(TM) SE Runtime Environment, 1.6.0_20-b02
OS: Linux

User Comments:
vladdraco: Compiling c++ code with heavy template usage. It takes about 30 seconds for gcc to compile single cpp file. Immediately after compilation successfuly finished IDE stuck for quite a long time.



Maximum slowness yet reported was 62004 ms, average is 13516
Comment 1 vladdraco 2010-05-12 14:13:41 UTC
Created attachment 98857 [details]
nps snapshot
Comment 2 Jaroslav Tulach 2010-05-17 13:39:25 UTC
The refresh and its calls to FolderChildren.getNodes() could possibly be executed outside of AWT thread, I guess.
Comment 3 Alexey Vladykin 2010-05-17 15:08:07 UTC
Fixed in http://hg.netbeans.org/cnd-main/rev/d07f5634621e
Comment 4 Quality Engineering 2010-05-19 06:11:48 UTC
Integrated into 'main-golden', will be available in build *201005182201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/
User: 
Log:
Comment 5 Alexey Vladykin 2010-05-25 09:50:00 UTC
*** Bug 186414 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo