Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 185747 - [69cat] Variant ${run.jvmargs} for use from <junit>
[69cat] Variant ${run.jvmargs} for use from <junit>
Status: RESOLVED DUPLICATE of bug 46298
Product: java
Classification: Unclassified
Component: Project
6.x
All All
: P3 with 1 vote (vote)
: TBD
Assigned To: Tomas Zezula
issues@java
:
: 185748 185749 (view as bug list)
Depends on: 122677
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-07 23:12 UTC by ulfzibis
Modified: 2010-05-10 20:40 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments
Screen shot (18.93 KB, image/png)
2010-05-07 23:16 UTC, ulfzibis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ulfzibis 2010-05-07 23:12:17 UTC
[ BUILD # : 201005050200 ]
[ JDK VERSION : 1.6.* ]

I often need separate properties for test cases, e.g.
-ea -esa
-verbose:gc
-Xbootclasspath
Comment 1 ulfzibis 2010-05-07 23:16:20 UTC
Created attachment 98668 [details]
Screen shot
Comment 2 ulfzibis 2010-05-07 23:29:33 UTC
*** Bug 185748 has been marked as a duplicate of this bug. ***
Comment 3 ulfzibis 2010-05-07 23:30:28 UTC
*** Bug 185749 has been marked as a duplicate of this bug. ***
Comment 4 Jesse Glick 2010-05-10 17:59:22 UTC
You can accomplish this with current IDE versions just by overriding -init-macrodef-junit in build.xml, but it may make sense to have a variant property available in the standard scripts and exposed in the GUI.
Comment 5 ulfzibis 2010-05-10 18:52:17 UTC
Not only run.jvmargs should be duplicated, I additionally think of
-application.args
-main.class
...
Comment 6 Jesse Glick 2010-05-10 19:49:17 UTC
No, application.args and main.class apply only to running classes with a main method.

*** This bug has been marked as a duplicate of bug 46298 ***
Comment 7 ulfzibis 2010-05-10 20:40:42 UTC
Sometimes I put benchmark classes in the test folder.
In that case separate application.args and main.class parameters would be useful.
But yes, this is a little aside the normal design.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo