Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 183885 - Netbeans doesn't show class name in variable view
Netbeans doesn't show class name in variable view
Status: RESOLVED DUPLICATE of bug 177039
Product: php
Classification: Unclassified
Component: Debugger
6.x
PC Linux
: P3 (vote)
: 7.0
Assigned To: rmatous
issues@php
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-12 11:14 UTC by derickr
Modified: 2010-07-23 23:55 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments
Screenshot with hints (18.69 KB, image/png)
2010-04-12 11:14 UTC, derickr
Details

Note You need to log in before you can comment on or make changes to this bug.
Description derickr 2010-04-12 11:14:58 UTC
Created attachment 97067 [details]
Screenshot with hints

Hello,

netbeans doesn't show the classname as "Value" for objects in the variable view. Because of this, I added something to Xdebug that adds a pseudo property "CLASSNAME" to every object to still be able to see the class name of an object. This is of course a hack, but it is really useful to have this information available. Could you please add this for the upcoming version?

This is related to bug https://netbeans.org/bugzilla/show_bug.cgi?id=182148 http://bugs.activestate.com/show_bug.cgi?id=86445 and http://bugs.xdebug.org/view.php?id=518 and http://bugs.xdebug.org/view.php?id=556 have background information.

regards,
Derick
Comment 1 derickr 2010-07-23 23:55:20 UTC

*** This bug has been marked as a duplicate of bug 177039 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo