Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 177039 - Debugger - variables pane does not show object type
Debugger - variables pane does not show object type
Status: VERIFIED FIXED
Product: php
Classification: Unclassified
Component: Debugger
6.x
All All
: P2 with 1 vote (vote)
: 6.x
Assigned To: rmatous
issues@php
69patch1-verified
:
: 183885 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-17 16:37 UTC by miked_187
Modified: 2010-07-23 23:55 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
screenshot of debugger panel showing missing values for objects (21.84 KB, image/png)
2009-11-17 16:37 UTC, miked_187
Details

Note You need to log in before you can comment on or make changes to this bug.
Description miked_187 2009-11-17 16:37:01 UTC
Created attachment 91214 [details]
screenshot of debugger panel showing missing values for objects

the debugging variables pane does not show the object type in the Value column.  see the attached screen shot.  

There is a discussion in the forum about this here: http://forums.netbeans.org/viewtopic.php?p=54665
Comment 1 miked_187 2010-04-09 19:41:45 UTC
who decides the priority on these issues?  any way to get this bumped up to a P1? it would seem kind of a glaring feature to be missing, at least in my world.  Issue still exists in 6.9M1, have not tried the nightly

similar to 163637 and 177039
Comment 2 Filip Zamboj 2010-04-12 13:30:11 UTC
(In reply to comment #1)
> who decides the priority on these issues?  any way to get this bumped up to a
> P1? 

No way, sorry. 
See http://wiki.netbeans.org/BugPriorityGuidelines

> it would seem kind of a glaring feature to be missing, at least in my
> world.  Issue still exists in 6.9M1, have not tried the nightly
> 
> similar to 163637 and 177039

I believe you. Actually, at the time being, I am not sure this is defect or enhancement. But, keep it as it is for now. 

Your QA ;).
Comment 3 raulv 2010-05-20 11:25:03 UTC
I've tried 6.8 and the latest nightly build and the variable list just shows 'object' for the type. The issue was originally reported for XP, I'm running Win7 so maybe that makes a difference.

Anyway, still this isn't very useful. It should show the object class.
Comment 4 Filip Zamboj 2010-05-20 13:13:25 UTC
(In reply to comment #3)
> I've tried 6.8 and the latest nightly build and the variable list just shows
> 'object' for the type. The issue was originally reported for XP, I'm running
> Win7 so maybe that makes a difference.
> 
> Anyway, still this isn't very useful. It should show the object class.

this is not platform related issue.
Comment 5 nadobnykh 2010-05-28 10:01:07 UTC
The showing of object class is very important for software evaluation/study, but also for debugging of OO PHP code!

The class name of the class the object was generated with is meant - please dont confuse with implementation class name, where the called method/variable is implemented (can be a super class or so)!

In OO PHP there is no "object" type, just as there is no "primitive" type (its a pointer type on interpreter tier). 

The type of object variable is always the classname with that the object was created! otherwise the debugger variables view is not really suitable for OO development (tracing/debugging)! i have 1000 classes and all are of type "object"? sorry, but not acceptable! :)  And there is no workaround, therefore P1!

i refer to ZendStudio implementation of Variables view! Furthermore, thats copyable - i can copy the content of the view, paste it to excel/openoffice calc and print it out for study! 

And please please please!... Its a big decision criterion for use NetBeans instead of ZendStudio

sorry for my bad english

best regards
Comment 6 rmatous 2010-05-28 10:28:26 UTC
Canditate for 6.9.1
Comment 7 miked_187 2010-05-28 15:46:38 UTC
@nadobnykh - no need for all the !!, comes across as kind of abusive in a CAPS like way.  Looking at the history shows that the issue was marked for fix in the next milestone release on the 20th of this month so the developers are aware of the issues and it is slated to be resolved.  Also look at the comments noted in this issue as to how issues are prioritized before 'demanding' a P1 status.  Play nice in the sandbox
Comment 9 Filip Zamboj 2010-05-31 14:26:53 UTC
fix has been verified in build 2010-05-31_15-03-59. 

Please, transplant into 69FCS after RC2 is out (current status for RC2 is NoGo due to fx composer issues). thanks.
Comment 11 Quality Engineering 2010-06-03 06:08:38 UTC
Integrated into 'main-golden', will be available in build *201006030001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/dfd90d3cfbb5
User: Radek Matous <rmatous@netbeans.org>
Log: #177039 - Debugger - variables pane does not show object type
Comment 12 Filip Zamboj 2010-06-09 20:39:07 UTC
verified in release69 clone 

Product Version: NetBeans IDE 6.9 (Build 100609-a94d6a4a87fe)
Java: 1.6.0_16; Java HotSpot(TM) 64-Bit Server VM 14.2-b01
Comment 13 rbalada 2010-06-14 08:28:23 UTC
Transplanted to release691 as 90d056757956
Comment 14 rbalada 2010-06-14 08:37:59 UTC
Added keyword 6.9.1_CANDIDATE to bugfixes, which were integrated in release69 repository *after* the release691 clone has been created.
Comment 15 Jaromir Uhrik 2010-07-08 14:48:11 UTC
Verified that the fix is available in the release691 repository.
Comment 16 derickr 2010-07-23 23:55:20 UTC
*** Bug 183885 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo