Bug 183556 - Self-profiling working in plain platform
Self-profiling working in plain platform
Status: RESOLVED FIXED
Product: profiler
Classification: Unclassified
Component: Engine
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Tomas Hurka
issues@profiler
:
: 164732 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-06 12:08 UTC by Jaroslav Tulach
Modified: 2011-06-07 16:15 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jaroslav Tulach 2010-04-06 12:08:14 UTC
Please modify the SelfProfileAction to work in plain platform without dependencies in profiler, so Jindra can finish his http://wiki.netbeans.org/HowToUseUIGesturesCollectorInYourApp
Comment 1 Tomas Hurka 2010-04-06 12:31:01 UTC
SelfProfileAction will store captured thread dumps and their timestamps into file with npss (NetBeans Profiler Stacktrace Stream) extension. This will allows us to do the CPU sampling without dependency on profiler code. Profiler will be modified to recognize and load npss files. There will be possibility to convert npss file to nps file for backward compatibility. This functionality will be use in the exception reporter, which will convert new npss files to nps files - this way people will be able to open snapshots in older NetBeans, which do not understand new npss file format.
Comment 2 Tomas Hurka 2010-04-08 14:07:16 UTC
Fixed in profiler-main
changeset:   166565:e8590489c11b
user:        Tomas Hurka <thurka@netbeans.org>
date:        Thu Apr 08 16:04:31 2010 +0200
summary:     bugfix #183556, slowness detector does not need profiler to save captured thread dumps
Comment 3 Quality Engineering 2010-04-09 04:54:17 UTC
Integrated into 'main-golden', will be available in build *201004090201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/e8590489c11b
User: Tomas Hurka <thurka@netbeans.org>
Log: bugfix #183556, slowness detector does not need profiler to save captured thread dumps
Comment 4 Tomas Hurka 2011-06-07 16:15:05 UTC
*** Bug 164732 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo