Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 181567 - Metadata plugin causing trouble?
Metadata plugin causing trouble?
Status: RESOLVED DUPLICATE of bug 181459
Product: java
Classification: Unclassified
Component: Project
6.x
PC Windows Vista
: P3 (vote)
: 6.x
Assigned To: Tomas Zezula
issues@java
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-05 05:58 UTC by javydreamercsw
Modified: 2010-03-15 13:05 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description javydreamercsw 2010-03-05 05:58:00 UTC
Build 201003040200

I'm getting this error while compiling:

Note: Creating the metadata factory ...
.
.
.
Note: ElementVisitor Package NOT IMPLEMENTED : games.jwrestling.server.core.action
error: java.lang.RuntimeException: Unable to load persistence.xml : Z:\Netbeans\jWrestling\jWrestling\build\classes\META-INF\persistence.xml (The system cannot find the path specified)
.
.
.
An annotation processor threw an uncaught exception.
Consult the following stack trace for details.
java.lang.RuntimeException: java.lang.RuntimeException: Unable to load persistence.xml : Z:\Netbeans\jWrestling\jWrestling\build\classes\META-INF\persistence.xml (The system cannot find the path specified)

At this point the build folder is empty.
Comment 1 javydreamercsw 2010-03-05 07:29:17 UTC
The same project compiles without issues on 6.8.
Comment 2 Tomas Zezula 2010-03-15 13:05:06 UTC
Seems that you have configured annotation processor for your project (probably eclipselink) which depends on existence of META-INF/persistence.xml in CLASSES_OUTPUT.
The NB 6.8 did not run annotation processors.

*** This bug has been marked as a duplicate of bug 181459 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo